camino 2.0b3pre (2009.02.26) crash [@ objc_msgSend][@ -[KeychainBrowserListener onLoadingCompleted:] ] after quit

RESOLVED INVALID

Status

Camino Graveyard
General
--
critical
RESOLVED INVALID
9 years ago
7 years ago

People

(Reporter: Mehmet, Unassigned)

Tracking

Details

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en; rv:1.9.0.8pre) Gecko/2009022600 Camino/2.0b3pre (like Firefox/3.0.8pre)
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en; rv:1.9.0.8pre) Gecko/2009022600 Camino/2.0b3pre (like Firefox/3.0.8pre)

Hello Camino-Team,

again camino 2b (latest nightly) crashed after quit (like resolved fixed bug: https://bugzilla.mozilla.org/show_bug.cgi?id=471948 )

Regards
Mehmet




Reproducible: Couldn't Reproduce

Steps to Reproduce:
1. right click on dock icon
2. select quit
3.
(Reporter)

Comment 1

9 years ago
Created attachment 364328 [details]
crash-log
Severity: normal → critical
Summary: camino 2.0b3pre (2009.02.26) crash after quit → camino 2.0b3pre (2009.02.26) crash [@ objc_msgSend][@ -[KeychainBrowserListener onLoadingCompleted:] ] after quit

Comment 2

9 years ago
Looks like we probably tore down a CHBrowserView without calling destroyWebBrowser, so the Keychain listener outlived the browser window. Unfortunately, the teardown process is not particularly straightforward.
(Reporter)

Comment 3

9 years ago
Created attachment 365566 [details]
Crash-log-05MAR2009

Hello Camino-Team,

today Camino crashed again after quitting with CMD+Q.

I noticed following behavior: After quitting Camino (CMD+Q) the dock-icon was still active. Complete quitting (after presseing CMD+Q again) was not possible. Then I clicked again on the dock-icon, a new window opens and crashed immediatly.

Thanks & regards
Mehmet

Comment 4

9 years ago
Stuart, does comment 2 mean there's a legitimate bug here, just that it's sort of complicated to figure out? Or is there something else we need information about to move this further along?

Comment 5

9 years ago
It means that I couldn't tell from quick inspection whether or not the scenario I described is possible; if it is, that would be definitely be a bug. Somebody will need to wade through that code and trace it back through call sites.

Comment 6

9 years ago
Mehmet: I don't recall if we ever asked this or not, but can you reproduce this crash with the Safari AdBlock InputManager disabled?
(Reporter)

Comment 7

9 years ago
(In reply to comment #6)
> Mehmet: I don't recall if we ever asked this or not, but can you reproduce this
> crash with the Safari AdBlock InputManager disabled?

Okay. I will deactivate Safari Adblock and will test it over the next days if the crash is reproducable in Camino.


You will hear from me :-)

Regards
Mehmet

Comment 8

9 years ago
Mehmet, have you had any luck reproducing this since you disabled that inputmanager?
(Reporter)

Comment 9

9 years ago
Hi Chris. Since I disabled Safari Adblock, Camino don't crash.

(But I must say, that Camino is more stable since fixed bug: https://bugzilla.mozilla.org/show_bug.cgi?id=471948 )

I will continue to test it.

Regards
Mehmet
(Reporter)

Comment 10

9 years ago
Hi Chris,

definitively no more crashes :-)

Regads
Mehmet

Comment 11

9 years ago
Stuart and I talked a bit on IRC this afternoon. While we might be able to bulletproof Camino against this sort of thing happening in the future, it seems unlikely enough that it's probably not worthwhile at the moment.

Please do let the developers of that InputManager know that they're crashing in this scenario, though, so they have a chance to investigate it and figure out what they can do on their end to be better-behaved.

INVALID, since the bug isn't in Camino code.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
(In reply to comment #11)
> Stuart and I talked a bit on IRC this afternoon. While we might be able to
> bulletproof Camino against this sort of thing happening in the future, it seems
> unlikely enough that it's probably not worthwhile at the moment.

FWIW, we did eventually do some bulletproofing in bug 512730.
You need to log in before you can comment on or make changes to this bug.