Redirects from Mozilla.com to MozillaMessaging.com

VERIFIED FIXED

Status

VERIFIED FIXED
10 years ago
6 years ago

People

(Reporter: sgarrity, Assigned: clouserw)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

We want to do this tomorrow morning around 10am PST.

Comment 2

10 years ago
Steven, can you add the appropriate class=external arrows to the various links on Mozilla.com...probably should indicate that people will be leaving the site now.

Thanks!
(Assignee)

Comment 3

10 years ago
Created attachment 364400 [details] [diff] [review]
add redirects

> http://getthunderbird.com -> http://www.mozillamessaging.com/en-US/thunderbird/

This redirect is something IT will have to do.  CCing oremj.

The other redirects are in the patch.  I modified them slightly to support any locale on the mozilla.com side and do locale detection on the mozillamessaging side (see patch for details).  Let me know if that's not desired.

There are also a lot of existing pages for thunderbird on moz.com  What's the plan for those.  Will they all be migrated?

> Please double-check with rebron before actually going to production with this.

Giving us a half day notice is already pretty short.  Rebron:  if you want this please a+ this bug asap.
Attachment #364400 - Flags: review?(reed)
(In reply to comment #3)
> > http://getthunderbird.com -> http://www.mozillamessaging.com/en-US/thunderbird/
> 
> This redirect is something IT will have to do.  CCing oremj.

It doesn't have to be done immediately, as it will get redirected there anyway if you do the http://www.mozilla.com/en-US/products/thunderbird/ ->
http://www.mozillamessaging.com/en-US/thunderbird/ redirect. However, just file an IT bug for that, and somebody can get to it.
(Assignee)

Comment 5

10 years ago
> Giving us a half day notice is already pretty short.  Rebron:  if you want this
> please a+ this bug asap.

(In reply to comment #1)
> We want to do this tomorrow morning around 10am PST.

Comments came in while I was making the patch; didn't see your comment when I posted that.
Comment on attachment 364400 [details] [diff] [review]
add redirects

Shouldn't these urls be with en-US/
(In reply to comment #0)
> http://www.mozilla.com/en-US/thunderbird/2.0.0.19/releasenotes/ ->
> http://www.mozillamessaging.com/en-US/thunderbird/2.0.0.19/releasenotes/

Are you going to be maintaining release notes for minor versions going forward even though the Mozilla Corporation is still doing them? If not, I either need access to mozillamessaging.com or this should remain on mozilla.com.
I'd also note that we need to make sure the redirect is correct for beta versions going forward.
I would prefer to host on mozillamessaging.com.  We can get you access or we can put it up for you, either way.
(Assignee)

Comment 10

10 years ago
(In reply to comment #6)
> (From update of attachment 364400 [details] [diff] [review])
> Shouldn't these urls be with en-US/
That's the locale detection I mentioned in comment 3

(In reply to comment #8)
> I'd also note that we need to make sure the redirect is correct for beta
> versions going forward.
I didn't add any future-proof URLs.  I assumed they would be maintained at mozillamessaging.com from now on.
(In reply to comment #10)
> (In reply to comment #8)
> > I'd also note that we need to make sure the redirect is correct for beta
> > versions going forward.
> I didn't add any future-proof URLs.  I assumed they would be maintained at
> mozillamessaging.com from now on.

Then we should redirect all of /thunderbird/2.0.0.x/releasenotes so that they can maintain it on their end. As it stands now, we'll have to add a new one for each 2.0.0.x release since the URLs are hardcoded in Thunderbird (unless there's a bug to change them in Thunderbird 2, but I haven't seen one).
(And yes, that'd mean migrating all old 2.0.0.x release notes over.)

Updated

10 years ago
Attachment #364400 - Flags: review?(reed) → review+
Comment on attachment 364400 [details] [diff] [review]
add redirects

Can you put these further down in .htaccess, say above the other MoMo redirects ("# Redirect the Thunderbird 3 release notes and start page to www.mozillamessaging.com")?

>+RewriteRule ^(\w{2,3}(?:-\w{2}(?:-mac)?)?/)?products/thunderbird/2.0.0.19/releasenotes[/]?$ http://www.mozillamessaging.com/thunderbird/2.0.0.19/releasenotes/ [R=permanent]

Temporarily, this is ok, but this isn't going to work long-term.

Again, I'll repeat what Wil said. Please give us more advanced notice for stuff like this in the future. Thanks.
(Assignee)

Comment 14

10 years ago
Patch is on trunk, will be on stage soon.  Need QA sign off before it goes live.

Comment 20

10 years ago
(re Comment 3)

If I am on the page- http://www.mozillamessaging.com/en-US/thunderbird/all.html
and change the language setting to say "French", I am redirected to the Firefox 3(french) homepage instead of Thunderbird(french) homepage.

Is this the expected behavior?
(Assignee)

Comment 21

10 years ago
It may not be what the user expects but it's not a new behavior.
Stephen, can we get another look on the latest patch?
(Assignee)

Comment 24

10 years ago
pushed in r22817.  Comment 2 is bug 481055.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
I'll file those thanks.
Verified FIXED on production for the URLs in the first part of comment 25, plus http://www.mozilla.com/en-US/thunderbird/all.html
Status: RESOLVED → VERIFIED
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.