river view reloads when traversed in page history

RESOLVED FIXED

Status

Mozilla Labs
Snowl
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: myk, Assigned: myk)

Tracking

({regression})

Details

(Assignee)

Description

9 years ago
When you go back or forward through page history to the river view, it now reloads the view.  It looks like this is a regression from a recent change that added an unload handler to the collections view, which disables the bfcache <https://developer.mozilla.org/en/Using_Firefox_1.5_caching>.

Since it can take time to build the river view, and we want to preserve the user's place in it when they traverse page history, it should be cacheable by the bfcache, so there shouldn't be an unload handler in it.

Comment 1

9 years ago
ah yes.  in the case of closing river (via closing tab or the button) we do need to run the unload handlers.  but in the case of page back/forward, we don't.  an onunload is sent in both cases..

i'll take a look at smartening this up.

Comment 2

9 years ago
fixed bd1214988d41.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.