All users were logged out of Bugzilla on October 13th, 2018

Creating new profile fails, calendar list and views are empty [Error: calMgr is not defined]

RESOLVED FIXED in 1.0b1

Status

--
critical
RESOLVED FIXED
10 years ago
9 years ago

People

(Reporter: ssitter, Assigned: Fallen)

Tracking

({dataloss, regression})

Trunk
1.0b1
x86
All
dataloss, regression
Bug Flags:
blocking-calendar1.0 +

Details

(Whiteboard: [needed beta][no l10n impact])

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
Created attachment 364371 [details]
screenshot of issue

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090226 Calendar/1.0pre (BuildID: 20090226084848)

Steps to Reproduce:
1. Start Sunbird with new profile

Actual Results:
The calendars tab is empty, the views are just white. Error Console shows:

Error: calMgr is not defined
Source File: chrome://calendar/content/calendar-management.js
Line: 100

Error: calendar is null
Source File: chrome://calendar/content/calendar-task-editing.js
Line: 134

Regression range: Works in Sunbird 1.0pre (20090226042528)
                  Fails in Sunbird 1.0pre (20090226084848)
(Assignee)

Updated

10 years ago
Assignee: nobody → philipp
Status: NEW → ASSIGNED
Flags: blocking-calendar1.0+
Whiteboard: [needed beta][no l10n impact]
(Reporter)

Comment 1

10 years ago
Same error with Lightning 1.0pre (2009022612 hourly) + Shredder 3.0b3pre.
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b3pre) Gecko/20090227 Calendar/1.0pre

I'm seeing this too, on Linux. Calendar list is empty, all events are there, but displayed on white background instead of their respective *.ics calendars' colours. (I use several local *.ics files outside my profile, one read-only on the Web, no implicit "default" calendar.)

Displaying an event's properties shows the appropriate calendar's name, but the calendar itself cannot be accessed.

Yesterday's nightly didn't have the problem.

Error console contains the following immediately after startup:

Error: setting a property that has only a getter
Source File: chrome://calendar/content/calendar-task-tree.xml
Line: 1049
--- (20 times, two at a time, with Javascript errors in between)

Error: [Exception... "'[JavaScript Error: "setting a property that has only a getter" {file: "chrome://calendar/content/calendar-task-tree.xml" line: 1049}]' when calling method: [calIOperationListener::onOperationComplete]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: file:///usr/local/sunbird/components/calCompositeCalendar.js :: anonymous :: line 550"  data: yes]
--- (11 times, each of them except the last [in First > Last order] immediately after two of the above)


If this is a different bug, please say so in a comment and set the platform back to Windows, I'll register a Linux bug in that case.

This is a no-go for me, I'm going back to yesterday's nightly until it's fixed.
Severity: major → critical
Keywords: dataloss
OS: Windows XP → All
(Reporter)

Comment 3

10 years ago
The problem is somewhere in the refactoring of loadCalendarManager() and initHomeCalendar() in calendar-management.js that was done in Bug 475715.

I added |let calMgr = getCalendarManager();| to initHomeCalendar() to run into the following error: "composite is not defined".

I added |let composite = getCompositeCalendar();| to initHomeCalendar() to run into the following exception: "Calendar list has no composite calendar yet".
Blocks: 475715
(Reporter)

Comment 4

10 years ago
(In reply to comment #2)
See also Bug 479316 for the 'setting a property that has only a getter' error. I only observed the error in a 1.9.2 but not 1.9.1 build. Maybe you could drop a note if it happens in a nightly build too.
In reply to comment #4:
Comment #2 is about the Linux build downloaded a few minutes before the comment was posted, from ftp://ftp.mozilla.org/pub/mozilla.org/calendar/sunbird/nightly/latest-trunk/. Its UA string was copied from Help=>About to the clipboard, then pasted from there at the top of the comment. AFAIK, there are no Calendar builds based on Gecko 1.9.2 on the Mozilla site yet. (I don't have the facilities or the know-how to compile Mozilla applications locally.)
(Reporter)

Updated

10 years ago
Summary: Calendar list and views are empty after startup [Error: calMgr is not defined] → Creating now profile fails, calendar list and views are empty [Error: calMgr is not defined]
(Reporter)

Updated

10 years ago
Summary: Creating now profile fails, calendar list and views are empty [Error: calMgr is not defined] → Creating new profile fails, calendar list and views are empty [Error: calMgr is not defined]
(Reporter)

Comment 6

10 years ago
Ought to be fixed by the checkin of attachment 365021 [details] [diff] [review] in Bug 475715.
Target Milestone: --- → 1.0
(Reporter)

Updated

10 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
(Assignee)

Updated

9 years ago
Target Milestone: 1.0 → 1.0b1
You need to log in before you can comment on or make changes to this bug.