Closed Bug 480388 Opened 12 years ago Closed 12 years ago

New Account Wizard is shown on every startup although RSS account exists

Categories

(MailNews Core :: Feed Reader, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED
Thunderbird 3.0b3

People

(Reporter: ssitter, Assigned: rain1)

References

Details

(Keywords: regression)

Attachments

(2 files)

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090226 Shredder/3.0b3pre (BuildID: 20090226032557)

Steps to Reproduce:
1. Start Thunderbird with new profile
2. In the New Account Wizard select "RSS News & Blogs"
3. Click "Next", confirm name, click "Next", click "Finish"
4. Restart Thunderbird

Actual Results:
New Account Wizard is shown again. Canceling the wizard shows the previously created RSS account in the folder pane.

Expected Results:
New Account Wizard is not shown on every startup.

Issue doesn't exists in Thunderbird 2.0.0.19 (20081209).
Confirming on Vista. Nothing in the JS console.
Status: UNCONFIRMED → NEW
Component: General → RSS
Ever confirmed: true
QA Contact: general → rss
Flags: blocking-thunderbird3?
Blocking because this is a regression.  That said, RSS is not a focus of Tb3, and this seems likely to be a _really_ unusual use case, so this is at risk of falling off the bandwagon somewhere down the line.  

It would be interesting to know when this regressed, as that might provide insight into the fix; adding qawanted.
Assignee: nobody → dmose
Flags: blocking-thunderbird3? → blocking-thunderbird3+
Keywords: qawanted
Target Milestone: --- → Thunderbird 3.0rc1
Regression range:

Works in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a2pre) Gecko/20080818131059 Shredder/3.0b1pre

Fails in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a2pre) Gecko/20080819031251 Shredder/3.0b1pre

Checkins during regression range:

https://hg.mozilla.org/comm-central/pushloghtml?startdate=2008-08-18+13:10:59&enddate=2008-08-19+03:12:51

https://hg.mozilla.org/releases/mozilla-1.9.1/pushloghtml?startdate=2008-08-18+13:10:59&enddate=2008-08-19+03:12:51
(In reply to comment #4)
> Possibly bug 432920?

Yes, I can see why that would cause this. I haven't stepped through the code, but my guess would be that since the RSS and blogs account is an identity-less account, and I changed the wizardCallback at initial startup from null to non-null, http://mxr.mozilla.org/comm-central/source/mailnews/base/prefs/resources/content/accountUtils.js#155 is true.
Reassigning to sid0 in the hopes that he'll be willing to take a run at this in the Tb3 timeframe.  Sid, if so, please change the state of the bug from NEW to ASSIGNED.  Thanks!
Assignee: dmose → sid.bugzilla
Blocks: 432920
I'll take a look at it.
Status: NEW → ASSIGNED
So, yes, that was the problem -- here's a patch that adds an extra parameter to verifyAccounts to differentiate between initial startup and compose window.
Attachment #366881 - Flags: superreview?(bienvenu)
Attachment #366881 - Flags: review?(bienvenu)
Attached file Litmus test
(In reply to comment #9)
> Created an attachment (id=366885) [details]
> Litmus test

do you plan to enter the litmus testcase in litmus too ?
(In reply to comment #10)
> (In reply to comment #9)
> > Created an attachment (id=366885) [details] [details]
> > Litmus test
> 
> do you plan to enter the litmus testcase in litmus too ?

Yes.
Keywords: qawantedregression
OS: Windows XP → All
Hardware: x86 → All
Target Milestone: Thunderbird 3.0rc1 → Thunderbird 3.0b3
Attachment #366881 - Flags: superreview?(bienvenu)
Attachment #366881 - Flags: superreview+
Attachment #366881 - Flags: review?(bienvenu)
Attachment #366881 - Flags: review+
Keywords: checkin-needed
Comment on attachment 366881 [details] [diff] [review]
Add extra parameter to verifyAccounts to differentiate between callers, v1
[Checkin: Comment 12]


http://hg.mozilla.org/comm-central/rev/b2c18a94c628
Attachment #366881 - Attachment description: Add extra parameter to verifyAccounts to differentiate between callers, v1 → Add extra parameter to verifyAccounts to differentiate between callers, v1 [Checkin: Comment 12]
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Wayne or Ludovic -- can we get this into Litmus?
Flags: in-litmus?
Component: RSS → Feed Reader
Product: Thunderbird → MailNews Core
This bug will still reproduce on thunderbird 3.0beta2,but has be fixed in thunderbird 3.0beta3
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.