'Click Here to Add New Task' quick-task-entry-textfield does nothing

RESOLVED WORKSFORME

Status

Calendar
Tasks
--
trivial
RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: mmolle, Unassigned)

Tracking

Sunbird 0.8
x86
Linux

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.6) Gecko/2009020409 Iceweasel/3.0.6 (Debian-3.0.6-1)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.13pre) Gecko/20080916 Debian/unstable (Codename:	sid) Iceowl/0.8

In fact, it does something. Throwing the following exception:

Error: [Exception... "'<error>' when calling method: [calICalendar::addItem]"  nsresult: "0x804a0002 (<unknown>)"  location: "JS frame :: file:///usr/lib/iceowl/js/calTransactionManager.js :: cT_doTransaction :: line 167"  data: no]
Source File: file:///usr/lib/iceowl/js/calTransactionManager.js
Line: 167

Error: [Exception... "'<error>' when calling method: [calICalendar::addItem]"  nsresult: "0x804a0002 (<unknown>)"  location: "JS frame :: file:///usr/lib/iceowl/js/calTransactionManager.js :: cT_doTransaction :: line 167"  data: no]
Source File: file:///usr/lib/iceowl/js/calTransactionManager.js
Line: 167

Error: [Exception... "'<error>' when calling method: [calICalendar::addItem]"  nsresult: "0x804a0002 (<unknown>)"  location: "JS frame :: file:///usr/lib/iceowl/js/calTransactionManager.js :: cT_doTransaction :: line 167"  data: no]
Source File: file:///usr/lib/iceowl/js/calTransactionManager.js
Line: 167

Error: uncaught exception: [Exception... "'<error>' when calling method: [calICalendar::addItem]"  nsresult: "0x804a0002 (<unknown>)"  location: "JS frame :: file:///usr/lib/iceowl/js/calTransactionManager.js :: cT_doTransaction :: line 167"  data: no]

--8<----

Of cource I tested with 'iceowl -safe-mode'.

I use 2 calenders, where one is a read-only http://blahbla/foobar.ics thing and one is my local file:///home/me/cal.ics (in which the task should be saved. can I configure that somehow?)

Additionally I use syncSW from scheduleworld.com. But I don't think that has something to do with this.


Reproducible: Always

Steps to Reproduce:
1. Click on the Textfield
2. Enter a Task-Title
3. Hit Return

Actual Results:  
no Task appearing

Expected Results:  
Task appearing

Comment 1

9 years ago
Do you use Sunbird or Lightning? What version?
(Reporter)

Comment 2

9 years ago
I posted a comment the day before yesterday, which seems to be gone now. Don't know why. Again. That Bug seemed to be my mistake. I should have selected the cal which was not read-only to add a task. (Then it worked) But sunbird(iceowl) should give an error message in case it cannot add the task. (ENHANCEMENT Request)

You ask for a version. It's up there in the init-posting.

Debian/unstable (Codename:    sid) Iceowl/0.8

So this is the 'sunbird' thingie, not lightning.

The Debian reportbug facility directs me here, to directly post the bugs to you upstream (even though they rebranded your stuff.)
Severity: normal → trivial
Version: unspecified → Sunbird 0.8

Comment 3

9 years ago
This is already fixed in Sunbird 0.9 that was released over 5 months ago. If you select a read-only calendar the entry is disabled and shows "Please Select a Writable Calendar". You can get the latest release from <http://www.mozilla.org/projects/calendar/> if Debian doesn't update its Iceowl fork.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

9 years ago
Thank you very much for your patience. Debian will update sooner or later. I'll just wait in comfortably knowing everything is fine ;)
You need to log in before you can comment on or make changes to this bug.