Tooltips for text area formatting tool bar have leading spaces

VERIFIED FIXED in 1.0

Status

support.mozilla.org
General
--
minor
VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: krupa, Assigned: paulc)

Tracking

unspecified
x86
All

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: tiki_template, tiki_upstreamed, URL)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
Created attachment 364432 [details]
tool_tip

Steps to reproduce:
1.Login to support.mozilla.com
2.Click on "How to Contribute"
3.Click on "Writing new Knowledge Base articles" link under "Improve the
Knowledge Base"
4.Enter some text in the search field under "Quick edit an article " and hit
edit.
5.Mouse over on a few of the icons in the text formatting tool bar in the edit article page.
6.Notice the tooltip for icons like note,comment,heading etc 

expected results:
Tooltips don't have unnecessary leading spaces

actual result:
Icons like note,comment,heading etc have leading spaces in the tooltip.

additional info:
1.tooltip for bold and special characters have no leading spaces.
2.screenshot attached
pretty sure this is a dupe. I can dig for it if someone else doesn't have it offhand.  Thanks for bringing it up!
Hrm, I couldn't find it, but I only searched for "tip".
OS: Windows XP → All
I distinctly remember it being mentioned somewhere ages ago but my email is turning up nothing as well. Probably on the newsgroup then.
(Assignee)

Comment 4

9 years ago
Oh yeah, I've seen this since back in October :)
Sure, I'll take this, why not. Seems just a matter of changing the "hints" for those buttons.
Assignee: nobody → paul.craciunoiu

Comment 5

9 years ago
Here's the somewhat bizarre story: the toolbar items are sorted alphabetically. I believe Jason or Nelson added leading spaces to make sure the items are sorted in a particular order. 

If you just remove the leading spaces, you will most probably reorganize the whole toolbar, which is not something that we want. 

Sylvie, do you know if there is another way of sorting the buttons?

Comment 6

9 years ago
Yes it is a trick.
The quicktags are in complete rewriting - http://ui.tikiwiki.org/tiki-index.php?page=Quicktags - not sure it will be ready for tikiwiki3.0

But you can easily trim the space:
--------------------------------------------------------
--- templates/styles/mozkb/tiki-edit_help_tool.tpl	(revision 23202)
+++ templates/styles/mozkb/tiki-edit_help_tool.tpl	(working copy)
@@ -58,8 +58,9 @@
   <div>
     {*{cycle name='cycle'|cat:$qtnum values=$qtcycle|default:",,,</div><div>" advance=false print=false}*}
     {section name=qtg loop=$quicktags}
-      <a title="{tr interactive='n'}{$quicktags[qtg].taglabel}{/tr}" href="javascript:taginsert('{$area_name}','{$quicktags[qtg].tagId}');" onclick="needToConfirm = false;">
-        <img src='{$quicktags[qtg].tagicon}' alt='{tr interactive="n"}{$quicktags[qtg].taglabel}{/tr}' title='{tr interactive="n"}{$quicktags[qtg].taglabel}{/tr}' border='0' />
+{assign var='label' value=$quicktags[qtg].taglabel|regex_replace:"/^ +/":""}
+      <a title="{tr interactive='n'}{$label}{/tr}" href="javascript:taginsert('{$area_name}','{$quicktags[qtg].tagId}');" onclick="needToConfirm = false;">
+        <img src='{$quicktags[qtg].tagicon}' alt='{tr interactive="n"}{$label}{/tr}' title='{tr interactive="n"}{$label}{/tr}' border='0' />
       </a>
       {*{cycle name='cycle'|cat:$qtnum}*}
     {/section}
-----------------------------------------
Be careful the translation needs to be updated
(Assignee)

Comment 7

9 years ago
r23863 / r23864
Trimmed the titles.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.0
(Reporter)

Comment 8

9 years ago
Tool-tips look pretty now.Thanks Paul.
Verified.
Status: RESOLVED → VERIFIED

Updated

9 years ago
Whiteboard: tiki_template
Unlikely to still be there. All toolbar-related stuff was revamped.
Whiteboard: tiki_template → tiki_template, tiki_upstreamed
You need to log in before you can comment on or make changes to this bug.