If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Restart dialog needs title

VERIFIED FIXED in Future

Status

SeaMonkey
Installer
P2
normal
VERIFIED FIXED
17 years ago
13 years ago

People

(Reporter: Henrik Gemal, Assigned: Sean Su)

Tracking

Trunk
Future
x86
Windows 2000
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

17 years ago
The restart dialog that you sometimes are presented for in the installer needs a 
title. Currently it's just a titleless dialog.
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Priority: P3 → P2
(Assignee)

Comment 1

16 years ago
over to Ying?
Assignee: ssu → yxia
Status: ASSIGNED → NEW
Target Milestone: --- → mozilla0.9.8

Comment 2

16 years ago
Created attachment 64931 [details] [diff] [review]
Patch to add the window title
(Assignee)

Comment 3

16 years ago
Comment on attachment 64931 [details] [diff] [review]
Patch to add the window title

r=ssu
Attachment #64931 - Flags: review+

Updated

16 years ago
Blocks: 67067

Comment 4

16 years ago
Created attachment 65122 [details] [diff] [review]
One patch to fix both dialog title bugs, bug 48051 & bug 67067

bragg: "Technically they're both "clean-up" type bugs and they're both in the 
same sub-system (the install wizard).  I believe that there would actually be 
less chance of error in a single check-in than if it was split into 2. I think 

would be the safest (and most efficient by the way) checkin procedure for these

two bugs."

Updated

16 years ago
Target Milestone: mozilla0.9.8 → mozilla0.9.9

Updated

16 years ago
Attachment #65122 - Flags: review+

Updated

16 years ago
Whiteboard: [mcp-working]

Updated

16 years ago
Attachment #64931 - Attachment is obsolete: true
Comment on attachment 65122 [details] [diff] [review]
One patch to fix both dialog title bugs, bug 48051 & bug 67067

>     char szPort[MAX_BUF];
>     char szUserId[MAX_BUF];
>     char szPassword[MAX_BUF];
>     char szSelectDirectory[MAX_BUF];
>     char szDirectories_[MAX_BUF];
>     char szDrives_[MAX_BUF];
>     char szStatus[MAX_BUF];
>     char szFile[MAX_BUF];
>     char szUrl[MAX_BUF];
>     char szTo[MAX_BUF];
>     char szAccept_[MAX_BUF];
>     char szNo_[MAX_BUF];
>     char szProgramFolder_[MAX_BUF];
>     char szExistingFolder_[MAX_BUF];
>     char szSetupMessage[MAX_BUF];
>+    char szRestart[MAX_BUF];
>     char szYesRestart[MAX_BUF];
>     char szNoRestart[MAX_BUF];
>     char szAdditionalComponents_[MAX_BUF];
>     char szDescription[MAX_BUF];
>     char szTotalDownloadSize[MAX_BUF];
>     char szSpaceAvailable[MAX_BUF];
>     char szComponents_[MAX_BUF];
>     char szDestinationDirectory[MAX_BUF];
>     char szBrowse_[MAX_BUF];
>     char szCurrentSettings[MAX_BUF];
>     char szInstall_[MAX_BUF];
>     char szDelete_[MAX_BUF];
>     char szExtracting[MAX_BUF];
>     char szReadme_[MAX_BUF];
>     char szPause_[MAX_BUF];

The amount of memory this represents is insane!

sr=dveditz, though
Attachment #65122 - Flags: superreview+

Comment 6

16 years ago
Ying, this has been reviewed and super-reviewed.  Do you want me to check it in
for you?

Comment 7

16 years ago
Curt, Please checkin for Ying. Ying is on vacation. Thanks.

Updated

16 years ago
Target Milestone: mozilla0.9.9 → mozilla1.0
(Reporter)

Comment 8

16 years ago
this never got checked in.
to reproduce:
start the talkback.exe and leave it open while installing mozilla.

the dialog is title less and says:
"Setup has finished..."

shouldn't is say "Mozilla Setup has finished..."

20020302

Comment 9

16 years ago
Ying is this needed for MachV? If yes, please work with your manager to get this
one nsbeta1+.

Comment 10

16 years ago
Moving Netscape owned 0.9.9 and 1.0 bugs that don't have an nsbeta1, nsbeta1+,
topembed, topembed+, Mozilla0.9.9+ or Mozilla1.0+ keyword.  Please send any
questions or feedback about this to adt@netscape.com.  You can search for
"Moving bugs not scheduled for a project" to quickly delete this bugmail.
Target Milestone: mozilla1.0 → mozilla1.2

Updated

16 years ago
Keywords: nsbeta1
Target Milestone: mozilla1.2 → mozilla1.0

Comment 11

16 years ago
I'll take care of getting this checked in, once we get the nsbeta1 plussed, and
look into the other titleless dialog that Henrik identified.
Assignee: yxia → curt

Comment 12

16 years ago
I'm testing the patch again since it's old, and now I got Restart dialog always showing up at the end of installation. Still looking at it...

Comment 13

16 years ago
ssu, would you please take a look at this simple patch again?
It's very strange now. After I put the changes in the lastest build, and 
rebuild the setup.exe, looks like everything in installGui will be messed up, 
and the restart dialog will always show up. To me, it seems a memory problem.
Please help, Thanks!

Updated

16 years ago
Keywords: nsbeta1 → nsbeta1-

Updated

16 years ago
Whiteboard: [mcp-working]
(Reporter)

Comment 14

16 years ago
the restart text also refers to "the program". Could we please change that 
into "Mozilla"...

Comment 15

16 years ago
Please update this bug with an [adt1] - [adt3] impact rating (or take it off the
list if it doesn't even rate adt3.)  Thanks!

Updated

16 years ago
Target Milestone: mozilla1.0 → Future
(Assignee)

Comment 16

15 years ago
Comment on attachment 65122 [details] [diff] [review]
One patch to fix both dialog title bugs, bug 48051 & bug 67067

I've tested the patch and it works just fine.
Attachment #65122 - Flags: approval1.4b?

Comment 17

15 years ago
Comment on attachment 65122 [details] [diff] [review]
One patch to fix both dialog title bugs, bug 48051 & bug 67067

a=asa (on behalf of drivers) for checkin to 1.4b.
Attachment #65122 - Flags: approval1.4b? → approval1.4b+
(Assignee)

Comment 18

15 years ago
patch will be checked in along with bug 203194.
Assignee: curt → ssu
Depends on: 203194
(Assignee)

Comment 19

15 years ago
patch checked in again.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 20

15 years ago
verified - build 2003050211
Status: RESOLVED → VERIFIED
QA Contact: bugzilla → gbush
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.