Last Comment Bug 480570 - Slow response navigating through messages list (thread) if certain extensions are installed
: Slow response navigating through messages list (thread) if certain extensions...
Status: RESOLVED INVALID
:
Product: Thunderbird
Classification: Client Software
Component: Folder and Message Lists (show other bugs)
: Trunk
: x86 Windows XP
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-27 10:11 PST by IU
Modified: 2009-02-27 23:26 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description IU 2009-02-27 10:11:26 PST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090226 Lightning/1.0pre

With certain extensions installed, navigating from one message to another, in the messages list (thread) pane, is excruciatingly slow.  I've noticed this with a couple of extension: JunQuilla and Virtual Identity; and given other non-extension related slow-downs I have observed (e.g. Bug 479989), I have reason to believe this may in fact be a Shredder performance bug--especially given that there is no reason for the above extensions to be causing such performance hits.

NOTE: I am on a P3 933 MHz, so you may need a slower computer to properly observe the problem.

JunQuilla: https://addons.mozilla.org/en-US/thunderbird/addon/9886

"Virtual Identity": https://addons.mozilla.org/en-US/thunderbird/addon/594


Reproducible: Always

Steps to Reproduce:
1. Create a new profile and account then copy messages to it
2. With the preview pane open, use the Up/Down arrow keys to navigate
3. Note the time it takes to navigate
4. Install JunQuilla and restart
5. Again, with the preview pane open, use the Up/Down arrow keys to navigate 
6. Note the decline in navigation performance
Comment 1 Tyler Downer [:Tyler] 2009-02-27 10:19:54 PST
It seems like this is something you should report to the developers of the extensions causing this problem. Extensions will cause a slowdown in performance.
Comment 2 Kent James (:rkent) 2009-02-27 14:21:44 PST
Hi IU, let's discuss this here rather than on the JunQuilla forum, until we can clarify whether it's core or extension related. We can leave the status as invalid for now though to avoid a status war with Tyler.

I also run email on a relatively slow processor (1.2 GHz Pentium M on Windows XP). With JunQuilla plus TaQuilla installed, I can navigate through the message pane on Local as well as IMAP as fast as I can push the up and down arrows. So there must be something different between our systems.

I also installed Virtual Identity, and saw no problems.

But let's try to figure out where it is occurring. On JunQuilla, you can disable most of the functionality by removing the Uncertain folders in Tools/Addons/JunQuilla/Options, and by unselecting all junk-related columns in the thread pane (including the normal junk status column). Can you do that, and tell me if it changes anything?
Comment 3 IU 2009-02-27 16:34:46 PST
Thanks, Kent.  I've tried again and I see that the problem occurs after clicking to "Remove" the Uncertain folders then clicking OK.

So the extension appears to be messing something up.  One this happens The only way to get the performance back is to disable the extension and restart.

Next time the extension is enabled, performance is still okay until "Remove" Uncertain folders is again clicked.
Comment 4 IU 2009-02-27 23:26:49 PST
I did some more testing and I cannot figure out a pattern.  I get significant slowdown in my regular profile and a slight slowdown in a reasonably clean test profile.

The test profile has only one account, using it's own store (i.e. not using "Local Folders"), and I have just over 960 messages in each Inbox (the account's specific Inbox and the "Local Folders" Inbox).

On my regular profile, where the problem is much worse, I have a total of five email accounts and many more messages and folders.  Only one of the accounts is using "Local Folders."  All others have their own store.  With JunQuilla enabled, there are several messages appearing in each of the "Uncertain" folders (with the exception of one account that has no messages at all).

So I wonder if it's because of the messages in the "Uncertain" folder that the slowdown happens when the folders are removed.

Note You need to log in before you can comment on or make changes to this bug.