Highlight the solution to a forum thread

VERIFIED FIXED in 1.2

Status

VERIFIED FIXED
10 years ago
9 years ago

People

(Reporter: Noah, Assigned: paulc)

Tracking

({ue})

unspecified

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: sumo_only)

Attachments

(6 attachments, 1 obsolete attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090226 Firefox/3.0
Build Identifier: 

Answers that are deemed as solving a problem via "This answer solved my problem", should be highlighted with a green background or some such. To give a quick visual and a better understanding that there's something special about the 2nd post in a thread marked solved. Right now the grey background doesn't alert me to anything, and I didn't notice that answer had solved the thread until I noticed the timestamp, which was out of order [which I also thought was a bug].

Reproducible: Always
(Assignee)

Comment 1

10 years ago
This seems like something to consider for UI improvements. Any suggestions?

Comment 2

10 years ago
This has been discussed before but I don't think a bug was ever filed. 

Some ideas we have discussed include:

- Adding a prominent note at the top of the thread saying something like: "This topic has been resolved. <View solution>" -- the link would scroll down to the solution to the problem
- The reply that is the solution should be highlighted somehow, for example as a top banner/heading reading e.g.: "This post solved the problem in this topic."

Cc'ing Neil -- this is one of those bugs where your input would be really helpful.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: ue
Target Milestone: --- → Future
(Assignee)

Comment 3

10 years ago
Awaiting Neil feedback. Meanwhile will think about it...
Assignee: nobody → paul.craciunoiu

Comment 4

10 years ago
Apple adds a blue little box with a green star at the beginning of the thread's parent post with the text "This question is answered." The post that is the solution to the problem is marked with the same green star.

http://discussions.apple.com/thread.jspa?threadID=1243940

However, they don't make it possible to easily jump to the solution, so I think we can use this as a case study but make something better. We should definitely have a link saying e.g. "Jump to the answer to this question." We might also want to reinforce that the thread is solved at the end of the parent post, which is where the reader will be after reading the question and confirming that it's the same issue he/she is having him/herself.

E.g. something like this:

Firefox 3.0.7 hangs/crashes on startup (even in Safe-Mode) 
Firefox version: 3.0.7 Operating system: Vista
 _______________________________________________
[This question has been answered. <View answer>.]
[_______________________________________________]


I'm using Vista, I believe I'm up to date on all software. Aside from that the subject above describes it pretty well. 

I kept it open for 20 minutes but it doesn't get any better. In the end I can send a crash report to Microsoft, but that's it. Since all extensions are disabled in Safe-Mode I'm guessing this doesn't have to do anything with 3rd party apps. Besides, I didn't install anything since the update. 

 _______________________________________________
[ <Jump to the answer to this question>         ]
[_______________________________________________]
(Assignee)

Comment 5

10 years ago
Sounds good. Looks like we'll need an icon or two, and some styling. David, since you have more ideas about this, would you like to do a mockup?
(Assignee)

Comment 6

10 years ago
Created attachment 371021 [details]
demo solved answer

How's this David? Courtesy of my brother's vision after I described the idea :)
Attachment #371021 - Flags: review?(djst)
Oooh! looks really good!

A few suggestions to make the top notification fit in with the current design, all referencing the search bars:

1. Make the outer border thinner to match.
2. Make the background a gradient.
3. Give it the same shadow as the search bars.
4. Use the same font as the search bars.

It'd be pretty cool if you could put the check mark image from the top notification under the username in the post that has the answer, or maybe next to the avatar.
(Assignee)

Comment 8

10 years ago
Created attachment 371027 [details]
demo solved answer 2

Again, with my brother's help. Here's another one.
Attachment #371027 - Flags: review?(djst)

Comment 9

10 years ago
I think this looks terrific. Neil, any comments from a UX point of view?

Comment 10

10 years ago
I think this is good as well (sorry for the delay, this got lost in bugmail). My suggestion would be to not colour the background of the entire solved topic, as that can reduce readability. Instead, maybe just add a smaller heading similar to the one at the top of the page (the "This topic has been resolved" banner) and then add a 2-3 pixel border around the entire topic to help visually distinguish it from the other replies.

Comment 11

10 years ago
Would love to see this make it into 1.2, if possible.
Summary: Identify answers that solve a problem more easily → Highlight the solution to a forum thread
Target Milestone: Future → 1.2
(Assignee)

Comment 12

10 years ago
Should I ask my brother for a third mockup or is the latter fine?

Comment 13

10 years ago
I personally think it's fine. Maybe we could brighten the background color up slightly to reduce the potential readability issue?
(Assignee)

Comment 14

10 years ago
Sound good. I'll do that and show it up on staging for review. Hopefully I'll have time, by the end of this week.
(Assignee)

Comment 15

10 years ago
r26106 - committed about 3 hours ago.

It seems that minify's css is not updating again (may need IT on this). Once it shows up, you may check it out at https://support-stage.mozilla.org/tiki-view_forum_thread.php?forumId=1&comments_parentId=252717&amp;login#mark

I was hoping to have a live demo on staging (hence why I waited), but I'll post a screenshot instead.

I think we should think about including the text we had in the additional box at the top in the new design:
----
This thread has been closed as solved. If the steps outlined below do not help with your Firefox issue, please try <a>searching again</a> or <a>start a new thread</a>.
----
(Assignee)

Comment 16

10 years ago
Created attachment 379278 [details]
demo implemented (top)
(Assignee)

Comment 17

10 years ago
Created attachment 379279 [details]
demo implemented (bottom)

Comment 18

10 years ago
Rather than "Resolved" can we instead have "This solution has been verified" or even just "Verified solution"
(Assignee)

Comment 19

10 years ago
Yay, the minify's finally been updated! See it at the url in comment 15.

I can replace "Resolved" with "Verified solution". I'd like to have the whole list of desired changes before I commit again. See comment 15 again, we should merge the two boxes.
(In reply to comment #18)
> Rather than "Resolved" can we instead have "This solution has been verified" or
> even just "Verified solution"

I think that's going in the wrong direction. The text should be friendlier. "This answer worked!" or something like that.

Comment 21

10 years ago
"This answer solved the problem."
(Assignee)

Comment 22

10 years ago
r26301
Thanks David, after our conversation I've done the following changes:
* "Resolved!" to "This answer solved the problem."
* Switch font sizes between "This problem has been resolved." and "See solution!"
* Make the above two both of the same color (the darker green from "This problem has been resolved")
* Remove yellow notification box from top and leave it on bottom only
* Replace "resolved" with "solved" to be consistent
Again, I hope I didn't forget anything.
(Assignee)

Comment 23

10 years ago
Ah yes, and:
* Make the background color lighter for the solution thread
(It had already been committed, I forgot to mention it)
(Assignee)

Comment 24

10 years ago
David, if you could take a final look and give it a go, I'll commit this to 1.2 on prod as soon as we push 1.1 out the door :)

Comment 25

10 years ago
Where can this be tested / seen?

Also, you'll want to submit a patch and ask for review (always!).
(Assignee)

Comment 26

10 years ago
(In reply to comment #25)
> Where can this be tested / seen?
> 
> Also, you'll want to submit a patch and ask for review (always!).

See comment 15. Gotta run now, but I'll land a patch after my final today... :)
(Assignee)

Comment 27

10 years ago
Created attachment 382239 [details] [diff] [review]
prod-read patch

Patch of all changes. Attachment with images to follow.
Attachment #382239 - Flags: review?(laura)
(Assignee)

Comment 28

10 years ago
Created attachment 382240 [details]
solvedtopic images, goes in webroot/styles/mozfr
(Assignee)

Updated

10 years ago
Attachment #371021 - Flags: review?(djst)
(Assignee)

Updated

10 years ago
Attachment #371027 - Flags: review?(djst)

Updated

10 years ago
Attachment #382239 - Flags: review?(laura) → review-

Comment 29

10 years ago
Comment on attachment 382239 [details] [diff] [review]
prod-read patch

I think there are bits missing from the patch. I checked out prod and applied the patch.  You can see it here:
http://laura.dm-sumotools01.mozilla.org/tiki-view_forum_thread.php?locale=en-US&comments_parentId=369220&forumId=1
(Assignee)

Comment 30

10 years ago
Created attachment 384038 [details] [diff] [review]
v2

The former yellow-box at the top was still showing up. Note that the actual answer thread in the post is not highlighted unless it has been marked by "This answer solved my problem". I believe many of the answered threads do not actually have a solved thread set, but that's not in the scope of this bug, AFAICT.
Attachment #382239 - Attachment is obsolete: true
Attachment #384038 - Flags: review?(laura)

Updated

10 years ago
Attachment #384038 - Flags: review?(laura) → review+

Comment 31

10 years ago
Comment on attachment 384038 [details] [diff] [review]
v2

Commit ASAP please.
(Assignee)

Comment 32

10 years ago
r28317 for prod
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Noah, when you have a chance, would you mind taking a look at this on staging?  (Comment 15 should do the trick.)  Thanks!
(Reporter)

Comment 34

10 years ago
Looks great! Thanks Paul!
I tested this too; looks good.

Verified FIXED (and thanks, Noah).
Status: RESOLVED → VERIFIED
Whiteboard: sumo_only
You need to log in before you can comment on or make changes to this bug.