TB3 b2 : LDAP server search problem in compose window

RESOLVED WORKSFORME

Status

Thunderbird
Message Compose Window
--
major
RESOLVED WORKSFORME
9 years ago
8 years ago

People

(Reporter: Abhinav Modi, Unassigned)

Tracking

({regression})

Trunk
x86
Linux
regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2009-11-26])

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.6) Gecko/2009020911 Ubuntu/8.10 (intrepid) Firefox/3.0.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b3pre) Gecko/20090223 Lightning/1.0pre Thunderbird/3.0b2

With TB3 b2, I get the following error while trying to search for a contact via ldap, in the compose window (by typing the address in the To: field)

<Ldap Server search problem>

Clicking on this error (which occurs just below the name being typed, as a drop-down opens a dialog box with the following :

Title : LDAP server search problem

Text :

Error code 0x80070057: Unknown error

Please contact your System Administrator.

However, going to the address book, selecting the ldap directory from the left pane, and typing the name does show the details properly.


Reproducible: Always

Steps to Reproduce:
1. Compose a new mail
2. Start typing the name of a person
3. The error occurs
Actual Results:  
There is an error in the To: field being populated with the name

Expected Results:  
The name and email should be populated

The ldap server is fine, and the settings all unchanged since TB2. As mentioned, the error does not occur when looking up name through the address book tab.
(Reporter)

Updated

9 years ago
Summary: LDAP server search problem → TB3 b2 : LDAP server search problem in compose window
(Reporter)

Updated

9 years ago
Severity: normal → major
Flags: wanted-thunderbird3?
Do you see any messages appearing in the error console when you try and do autocomplete? (tools -> error-console).

Comment 2

9 years ago
I see the same problem on a Mac.  There are no error messages on the console.  LDAP autocompletes worked fine in T2 and T3 beta 1.
(In reply to comment #2)
> I see the same problem on a Mac.  There are no error messages on the console. 
> LDAP autocompletes worked fine in T2 and T3 beta 1.

Please can you therefore answer comment 1?

Comment 4

9 years ago
I thought I had... "There are no error messages on the console."   I guess I should have said "error-console".

Updated

9 years ago
Keywords: regression
Version: unspecified → Trunk
I can't see much between b1 and b2 that changed here, except for maybe the password management items, but afaik they should be working fine.

Can you get a protocol log for ldap please and add it as an attachement to this bug? See https://wiki.mozilla.org/MailNews:Logging for details.

Comment 6

9 years ago
I've tried several things:  The first was to just turn on logging, and this is what I saw. 

-1604176096[120ab50]: nsLDAPOperation::SimpleBind(): called; bindName = ''; 
-1334579200[174cbde0]: nsLDAPConnection::Run() entered
-1604176096[120ab50]: nsLDAPSSLConnect(): standard connect() function returned -1
-1334579200[174cbde0]: unbinding
-1334579200[174cbde0]: unbound

This looked bad...like it wasn't reading my config.  So, I went in and 'touched' the config via the ldap account settings, and viola...the error went away.  The "touch" I did was to change the ldap server and Base DN to some garbage and then change it back.  

So..looks like config parsing?

Comment 7

9 years ago
Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1b3pre) Gecko/20090324

I don't see this with an anonymous simple bind. Are you using a bind dn?
(In reply to comment #7)
> Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1b3pre) Gecko/20090324
> 
> I don't see this with an anonymous simple bind. Are you using a bind dn?

Abhinav ?
Whiteboard: [closeme 2009-11-26]
RESO INCO per lack of response to last comment. If you feel this change was made in error, please respond to this bug with your reasons why.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 10

8 years ago
To address some of the comments in the thread (completely missed the mail notifications, was pointed to this discussion by Wayne) :

1. No Bind DN was used

2. This was failing till recently, but I tried to reproduce this on TB 3.0.4 and it worked. Build used :

(Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.9) Gecko/20100317 Lightning/1.0pre Thunderbird/3.0.4)


3. Not sure if this is a transient issue (esp on the server side ? Not very likely), or it's been fixed. 

I am moving this to Resolved / WORKSFORME for now. Will reopen if I see it again.

Thanks !
Resolution: INCOMPLETE → WORKSFORME
Flags: wanted-thunderbird3?
You need to log in before you can comment on or make changes to this bug.