Add ifdef MOZ_UPDATER for the app update preferences UI and Help menu

RESOLVED FIXED in 1.0b1

Status

defect
RESOLVED FIXED
10 years ago
8 years ago

People

(Reporter: rstrong, Assigned: rstrong)

Tracking

unspecified
1.0b1

Details

Attachments

(2 attachments)

Posted patch patch rev1Splinter Review
Spinoff of bug 464791 for Sunbird... Bug 477192 is the Thunderbird bug and bug 480696 is the SeaMonkey bug.

If Sunbird is compiled with --disable-updater the app update preferences UI should not be displayed. This simplifies the work Linux distros have to do since they don't use app update and don't want to display this ui. I am also considering making the js component for app update not be included when compiling with --disable-updater.
Attachment #364660 - Flags: review?(mschroeder)
Duplicate of this bug: 477194
Comment on attachment 364660 [details] [diff] [review]
patch rev1

r=mschroeder (just a quick code review, no testing)
Attachment #364660 - Flags: review?(mschroeder) → review+
Status: NEW → ASSIGNED
Robert, is the patch ready for checkin?
It should be unless SunBird supports flatchrome like SeaMonkey (see bug 480696) which I don't think it does.
Never heard of flat chrome in relation to Sunbird. I don't think Sunbird supports it because calendar code already has several files that require preprocessing.
Pushed to comm-central
http://hg.mozilla.org/comm-central/rev/d8c753c50b16
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.0
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b4pre) Gecko/20090407 Calendar/1.0pre

This patch doesn't works correctly. Official nightly builds are done without --disable-updater. Menu "Help > Check for Updates..." is available and works. 

But in the preference dialog the options to enable Sunbird updates are missing.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Problem is that advanced.js and advanced.xul are located in /calendar/base/content/preferences/ but the packaging happens in /calendar/resources/jar.mn that knows nothing about MOZ_UPDATER.
Attachment #371510 - Flags: review?(mschroeder)
Comment on attachment 371510 [details] [diff] [review]
bustage fix, v1

Looks good. r=mschroeder
Attachment #371510 - Flags: review?(mschroeder) → review+
Additional fix pushed to comm-central <https://hg.mozilla.org/comm-central/rev/192953f14966>
Status: REOPENED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → FIXED
These bugs are likely targeted at Lightning 1.0b1, not Lightning 1.0. If this change was done in error, please adjust the target milestone to its correct value. To filter on this bugspam, you can use "lightning-10-target-move".
Target Milestone: 1.0 → 1.0b1
You need to log in before you can comment on or make changes to this bug.