On some pages, Minefield Quick Find stops matching if word contains apostrophe character (')

VERIFIED INVALID

Status

()

Core
Find Backend
--
major
VERIFIED INVALID
9 years ago
9 years ago

People

(Reporter: IU, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

54.15 KB, text/html
Details
(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090227 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090227 Minefield/3.2a1pre

On some pages, Minefield Quick Find stops matching if word contains apostrophe character (').  An example is the linked URL (HTML page attached to this report).

When searching for the word "doesn't", matching is okay until the (')--at which point matching fails.


Reproducible: Always

Steps to Reproduce:
1. Either visit the linked URL or open the attached HTML file
2. Search for the word: doesn't
3. Notice that characters in the word are matched until the apostrophe is entered, at which point Minefield no longer finds the word.
(Reporter)

Updated

9 years ago
Component: General → Find Backend
Product: Firefox → Core
Version: unspecified → Trunk
(Reporter)

Comment 1

9 years ago
Created attachment 364760 [details]
test case

Comment 2

9 years ago
That's because that page doesn't contain an apostrophe (U+0027), but rather a RIGHT SINGLE QUOTATION MARK (U+2019) (’).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

9 years ago
Wow.  It's hard to visually see the difference on that page.  I had to copy it to a text editor to notice! :-) Thanks.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.