Cannot edit documents of any length in QMO without website resetting itself

VERIFIED WORKSFORME

Status

P1
critical
VERIFIED WORKSFORME
10 years ago
10 years ago

People

(Reporter: cmtalbert, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

10 years ago
I've attempted to do this three times on Friday, four times today :(

1. Go try and edit the "Introduction to Mozmill" document.
2. Try to remove the extra line feeds and format the main document properly using the interactive editor.

= Expected =
This would work

= Actual =
At some point the QMO sites starts trying to reload your tab.  Then it usually loses its network state and you lose your edits.  If you manage to get the edits back, it then tells you that the page has been modified by someone else and therefore you cannot edit it.

The message I received from the website was "connection to the server has been reset".

I got this both while working *in the mozilla office* and from here at the house.  I don't think it's a network issue, I'm not even on a wireless net.

My biggest question with this is why does the website need to reload itself while you are working on the content of a page?  What on earth is it trying to do?  And can we tell it to quit trying to do it?
(Reporter)

Comment 1

10 years ago
Another version of the issue.  You don't do anything untoward at all.

1. Edit your document
2. Click Save.

QMO says "connection interupted while communicating to the server.  

The document is gone.

Yay.  I'm getting really good at editing the first two paragraphs. :-)

I've tried it in both Minefield, Firefox 3.0.x and even Safari (the rendering on Safari is crap, but that's another bug (and probably apple's)).  

It seems to slow down much more on Minefield.  I wonder if this isn't exposing a memory leak in minefield.
(Reporter)

Comment 2

10 years ago
This actually works a quite a bit better in Firefox 3.0.x.  Bumping down to critical.  With enough persistence, and copy/paste, I'm actually making progress on my document! :D
Severity: blocker → critical
(In reply to comment #2)
> This actually works a quite a bit better in Firefox 3.0.x.  Bumping down to
> critical.  With enough persistence, and copy/paste, I'm actually making
> progress on my document! :D

oh i'm sorry that this happened, is this still a problem with Firefox 3.5 Clint ? 

Marking this as p1
Priority: -- → P1
Is there a sure way to reproduce this? What about with JS disabled?
I'm not seeing this, Clint. We need an update on this asap if its a critical bug. I'm giving the bug about 2 weeks lead time to be commented on otherwise, please close it as resolved:wfm. Whiteboard is being set to closeme by 7/14.
Whiteboard: closeme 7-14-09
(Reporter)

Comment 6

10 years ago
I'm not seeing thsi anymore. It might have been due to who-knows-what in early QMO and minefield.  Let's close it.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
v.
Status: RESOLVED → VERIFIED
Whiteboard: closeme 7-14-09
You need to log in before you can comment on or make changes to this bug.