Identity button should appear pressed when opening the identity popup

VERIFIED FIXED in Firefox 3.6a1

Status

()

Firefox
Theme
--
enhancement
VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: dao, Assigned: dao)

Tracking

({polish, verified1.9.1})

Trunk
Firefox 3.6a1
x86
Mac OS X
polish, verified1.9.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [polish-easy] [polish-interactive][polish-p1])

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

8 years ago
Created attachment 364907 [details] [diff] [review]
patch

We can't make the identity button a proper menu button as the favicon needs to be a drag source, but we can set and use the "open" attribute nevertheless.

Pinstripe already tries to use that attribute to some extent, and I'd like to use it for Winstripe as well.
Attachment #364907 - Flags: review?(gavin.sharp)
(Assignee)

Updated

8 years ago
Whiteboard: [polish-easy] [polish-interactive]
Comment on attachment 364907 [details] [diff] [review]
patch

>diff --git a/browser/themes/pinstripe/browser/browser.css b/browser/themes/pinstripe/browser/browser.css

>-#identity-box:active > #page-proxy-stack,
>+#identity-box:hover:active > #page-proxy-stack,
> #identity-box[open="true"] > #page-proxy-stack {
>   opacity: 0.75;
> }

Does this even do anything? I can't notice the difference...
Attachment #364907 - Flags: review?(gavin.sharp) → review+

Comment 2

8 years ago
dupe of bug 414473 (mac), but there's also bug 417079 (linux) and bug 431983 (windows)
(Assignee)

Updated

8 years ago
Duplicate of this bug: 414473
(In reply to comment #1)
> (From update of attachment 364907 [details] [diff] [review])
> >diff --git a/browser/themes/pinstripe/browser/browser.css b/browser/themes/pinstripe/browser/browser.css
> 
> >-#identity-box:active > #page-proxy-stack,
> >+#identity-box:hover:active > #page-proxy-stack,
> > #identity-box[open="true"] > #page-proxy-stack {
> >   opacity: 0.75;
> > }
> 
> Does this even do anything? I can't notice the difference...

These selectors don't match because there's a hbox between #identity-box and #page-proxy-stack.
(Assignee)

Comment 5

8 years ago
OK, apparently nobody missed that effect, so I'll remove these lines. Please file a new bug if you think we should make that work properly.
(Assignee)

Comment 6

8 years ago
Created attachment 364974 [details] [diff] [review]
landed patch
Attachment #364907 - Attachment is obsolete: true
Attachment #364974 - Flags: approval1.9.1?
(Assignee)

Comment 7

8 years ago
http://hg.mozilla.org/mozilla-central/rev/d4826b6af7a6
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.2a1
Verified fixed on the trunk using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20090303 Minefield/3.2a1pre as well as the latest nightly on 10.4. The shading ends up a bit dark, but I would have to see how it compares to the other OS's.
Status: RESOLVED → VERIFIED
Attachment #364974 - Flags: approval1.9.1? → approval1.9.1+
Comment on attachment 364974 [details] [diff] [review]
landed patch

a191=beltzner
(Assignee)

Updated

8 years ago
Keywords: checkin-needed
(Assignee)

Comment 10

8 years ago
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/86b0c8a3a9f1
Keywords: checkin-needed → fixed1.9.1
Verified fixed on the 1.9.1 branch using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b4pre) Gecko/20090423 Shiretoko/3.5b4pre. Adding keyword.
Keywords: fixed1.9.1 → verified1.9.1
This bug's priority relative to the set of other polish bugs is:
P1 - Polish issue that appears in the main window, or is something that the user may encounter several times a day.
Whiteboard: [polish-easy] [polish-interactive] → [polish-easy] [polish-interactive][polish-p1]
You need to log in before you can comment on or make changes to this bug.