Last Comment Bug 4810 - Win95-J: Japanese pages cause crash
: Win95-J: Japanese pages cause crash
Status: VERIFIED FIXED
QA BLOCKER:fixed in local tree; need ...
:
Product: Core
Classification: Components
Component: Internationalization (show other bugs)
: Trunk
: x86 Windows 98
P1 critical (vote)
: M5
Assigned To: Erik van der Poel
: blee
: Makoto Kato [:m_kato]
Mentors:
http://babel/tests/browser/bft/sjis/b...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 1999-04-08 15:48 PDT by blee
Modified: 2005-03-17 13:34 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description User image blee 1999-04-08 15:48:48 PDT
Try to display the page in the URL field above or another page in euc-jp,
http://babel/tests/browser/bft/euc-jp/bft_browser_form_euc-jp.html (reloading
required after initial page loading).

==> No JA char's are displayed correctly (under Win 98 JA).
This problem doesn't happen under Win NT JA. Under Win 95 JA, loading a JA
charset page force-quits the app (observed in 4/7 and 4/8 bld).
Comment 1 User image msanz 1999-04-08 16:47:59 PDT
Is this an M4 or M5 bug?
Comment 2 User image Frank Tang 1999-04-08 17:48:59 PDT
since this is a display problem, reassign this to erik.
Comment 3 User image Frank Tang 1999-04-08 17:49:59 PDT
erik- pay attention to blee's comment 'Under Win 95 JA, loading a JA
charset page force-quits the app" - this may related to bug 4800
Comment 4 User image blee 1999-04-28 12:54:59 PDT
With 4/28 bld under Win95 JA, test pages of the original bug description show up
properly after reloading and the problem seems fixed.
However, when a different JA page (eg, www.mainichi.co.jp or www.yomiuri.co.jp)
is loaded, reloading the page causes the entire chrome to turn black and any user
input/event after this leads to a machine shut down (not just a system crash).
Under Win98 JA with the same bld, the two newspaper pages can't be displayed
properly (garbage chars) even after reloading.

Couldn't try out Win95 KO due to network problem.
Comment 5 User image Teruko Kobayashi 1999-04-28 18:22:59 PDT
This is very critical, so I reopen this to get everybody attention.
Comment 6 User image bobj 1999-04-28 19:06:59 PDT
This sounds like a different bug.  If so, please open a new bug report.
The garbage displayed on Win98-ja for www.mainichi.co.jp sounds similar
to a frameset bug: 5644.  If you open the frame in a separate window,
it works.
Comment 7 User image Erik van der Poel 1999-04-29 22:24:59 PDT
Fixed in my local tree. Need to prepare for check-in.
Comment 8 User image leger 1999-04-29 23:38:59 PDT
Putting on QA Blocker List.
Comment 9 User image blee 1999-05-03 14:21:59 PDT
Verified fixed in 3/5 Win32 bld under Win95 JA and Win98 JA.

Note You need to log in before you can comment on or make changes to this bug.