make name of bugzilla installation configurable

RESOLVED DUPLICATE of bug 13540

Status

()

Bugzilla
Administration
P2
enhancement
RESOLVED DUPLICATE of bug 13540
18 years ago
5 years ago

People

(Reporter: Shiva Thirumazhusai, Assigned: Curt Patrick (gone))

Tracking

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

18 years ago
Everytime I upgrade to the Newest Bugzilla or get a fix, I need to modify 
various files to reflect that this instance is completely different than the
bugzilla bug database. To avoid doing the redundant work, I created a fix and 
I have attached the patch which will take the instance name as a Param value.
This patch will help change all the places where it says 'Bugzilla' instead of 
the Bugzilla instance name. 

I hope this solves my problem.
(Reporter)

Comment 1

18 years ago
Created attachment 12557 [details] [diff] [review]
Here is the patch to include instance name

Updated

18 years ago
Summary: To create an instance of Bugzilla → make name of bugzilla installation configurable
In looking over this patch, I think it's a little bit overzealous...

There are two basic contexts in which the word "Bugzilla" is used.  One refers to 
the site or the installation, the other refers to the software being run.  I 
agree that in the context of referring to the site or the installation it should 
be configurable.  In the context of referring to the software it should remain 
"Bugzilla".

Once case in particular where this would make sense is the statement "This is 
Bugzilla: the Mozilla bug system."  No matter what you're calling it, the 
software is still Bugzilla, and that's still what it is. :)   If you've made 
enough changes to justify renaming the software itself, then you're perfectly 
capable of editing that line in your params. :)

Speaking of params, I'm not sure if you can use Param() from inside defparams.pl, 
since many of them probably haven't been defined yet. :)  I would use the %% 
notation in there, just like the rest of the params use to refer to each other.
(Reporter)

Comment 3

18 years ago
>Once case in particular where this would make sense is the statement "This is 
>Bugzilla: the Mozilla bug system."  No matter what you're calling it, the 
>software is still Bugzilla, and that's still what it is. :)   If you've made 
>enough changes to justify renaming the software itself, then you're perfectly 
>capable of editing that line in your params. :)
My interest is not changing the Product Name. This patch is mainly to 
differentiate internal installation of the product and the external installation
of the product. I think this particular usage of Param may be ignored. 


>Speaking of params, I'm not sure if you can use Param() from inside 
>defparams.pl, since many of them probably haven't been defined yet. :)  I would 
>use the %% notation in there, just like the rest of the params use to refer to 
>each other.

For this particualar case %% didn't work and it forced to use Param().


Hmm, I guess blurbhtml isn't defined as being able to use other stuff in it...  
but no reason it couldn't be.
(Reporter)

Comment 5

18 years ago
Created attachment 12775 [details] [diff] [review]
New patch for configuring bugzilla instance name.
(Reporter)

Updated

18 years ago
Priority: P3 → P1

Comment 6

18 years ago
landfill is currently being relocated to a new network to allow for ssh access 
from any desginated 'approved' host.

soon as this happens, we can open up landfill for usage from outside parties. 

Comment 7

18 years ago
so i noticed that the priority got bumped to P1, and that this bug is marked as 
'blocking'. Who am I am I blocking exactly, and why is this considered a P1 bug?
(Reporter)

Comment 8

18 years ago
I have created this patch to enable Bugzilla(Software NOT website) users to 
customize and upgrade to the latest source without much hassle.

In Netscape, we have a bug database for Internal Use(Netscape 6). Whenever I
upgrade I have to manually change(prone to problems) atleast 10 files to say it 
is different than http://bugzilla.mozilla.org. otherwise people are writing bugs 
pertaining to mozilla in internal bug database. This prevents me from upgrading 
to the latest. I have upgraded Internal Bug Database to enable MOVE feature and
after that Removing cc is not working. If we can add the stated patch that will 
help me to upgrade to latest source. This patch is very useful to people who are 
using bugzilla for their local customized installations. 

Comment 9

18 years ago
adding hieniken+ and bostoncream+ keyword
Whiteboard: hieniken+, bostoncream+
<Aside: Has chofmann gone nuts? ;-)>
                                                                    
namachi@netscape.com - I can't quite understand why you "keep upgrading". Surely 
you pick a stable version of Bugzilla and then stick with it for a few months? I 
can't believe you are running Netscape's internal bug database for NS 6 on the 
unstable Bugzilla tip code...

Gerv

Comment 11

18 years ago
known to be a resident of the nut house since 1996.
(Reporter)

Comment 12

18 years ago
I started with installing a stable version and Upgraded to CVS tip to include
the much wanted 'MOVE BUG' feature. This came with a different bug(Removing CC 
user from CC list). Every time when I upgrade I have to change some files. This 
made me to do the the above mentioned patch. If everybody things the patch is 
not useful to others then lets mark it as INVALID and I will find a 
different solution for my upgrade issue.
Ah, of course. I forgot about MOVE - you do need that, of course.

We need to work towards a stable Bugzilla release with the new stuff in; but 
tara and cyeh seem to be a bit busy at the moment.

<goes back into hiding>

Gerv

Comment 14

18 years ago
patch being tested on landfill. i had to make a few space and syntax corrections 
on the patch. please beat up on it for a day or two. i don't have time to give 
it a complete review.

Status: NEW → ASSIGNED

Comment 15

18 years ago
something is broken. The new bugzilla-name parameter works in page titles
bug when I substitute "%bugzilla-name% for "Bugzilla" in various fields
on landfill's params page, its broken.  e.g. the bugzilla version shows
up as "%bugzilla-name% version 2.11" and when it mails me my password
I get "Subject: Your %bugzilla-name% password.".

Comment 16

18 years ago
I can understand this being a problem for Bugscape, but it's not a P1 blocker.  
Downgrading and adding 2.12 keyword.
Severity: blocker → critical
Priority: P1 → P2
Whiteboard: hieniken+, bostoncream+ → 2.12

Comment 17

18 years ago
is there an updated patch for this that works and is based off of the current 
bugzilla trunk?
(Reporter)

Comment 18

18 years ago
cyeh - can you create an account for me in landfil ? To update and test 
this patch.
Thanks,

Comment 19

17 years ago
Last I knew, Curt was working on this.  Reassigning to him, and taking it off
the 2.12 list.  Don't think we need to wait for this.
Assignee: cyeh → curt
Status: ASSIGNED → NEW

Comment 20

17 years ago
Last I knew, Curt was working on this.  Reassigning to him, and taking it off
the 2.12 list.  Don't think we need to wait for this.
Whiteboard: 2.12
Whiteboard: 2.14

Updated

17 years ago
Whiteboard: 2.14 → 2.16
moving to real milestones...
Target Milestone: --- → Bugzilla 2.16
This bug hasn't been touched in almost 7 months, and has a patch that is now too 
stale to apply.  Namachi, did you have this working?  Is there a newer patch 
available?  Have the other problems mentioned in the comments here since that 
patch been addressed?
Keywords: patch, review

Updated

17 years ago
Component: Bugzilla → Administration
Product: Webtools → Bugzilla
Version: other → 2.10
Removing patch keyword until namachi, or someone else, comes up with an
up-to-date patch.

Gerv
Keywords: patch, review
Enhancement with no patch; -> 2.18.

Gerv
Severity: critical → enhancement
Target Milestone: Bugzilla 2.16 → Bugzilla 2.18
*** Bug 129039 has been marked as a duplicate of this bug. ***
Blocks: 123130
Whiteboard: 2.16

Updated

16 years ago
Attachment #12557 - Attachment is obsolete: true
Comment on attachment 12775 [details] [diff] [review]
New patch for configuring bugzilla instance name.

This will need updating for the templatisation
Attachment #12775 - Flags: review-
This got fixed when the variables.none.tmpl template was created.

*** This bug has been marked as a duplicate of 13540 ***
No longer blocks: 123130
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Target Milestone: Bugzilla 2.18 → ---

Comment 28

12 years ago
Has this enhancement gone through and finished. We had similar problems and would like to know if the latest patches are avaiable if we are installing the bugzilla again.

QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.