If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

make it possible to only created data compliant with the calendaring standards

RESOLVED INVALID

Status

Calendar
General
RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: Jelle de Jong, Unassigned)

Tracking

Sunbird 0.9
x86
Linux

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.6) Gecko/2009020409 Iceweasel/3.0.6 (Debian-3.0.6-1)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.18pre) Gecko/20090113 Debian/5.0 (Codename: lenny) Iceowl/0.9

events and taskts made with iceowl do not show in GNOME evolution, event made with GNOME evolution do show in iceowl.

Can we make sure the created data is standard compliance and will work with other calender applications>?

Reproducible: Always
(Reporter)

Comment 1

9 years ago
http://www.calconnect.org/calendaringstandards.shtml
(Reporter)

Updated

9 years ago
Version: unspecified → Sunbird 0.9

Comment 2

9 years ago
Are you speaking of the iCalendar standard (RFC 2445)? All ics files created by Sunbird/Lightning are already valid according to the iCalendar standard (latest version <http://tools.ietf.org/html/draft-ietf-calsify-rfc2445bis-09>). You can check the validity yourself at <http://severinghaus.org/projects/icv/>.
Please report bugs in Evolution to the evolution team. As Stefan points out, we absolutely create valid RFC 2445 calendar files.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

9 years ago
Many thanks for the link, i will use it in my bug reports against evolution, the exported calender file show indeed as valid. But it strange since events made with evolutions do show up in iceowl and evolution and when exported with iceowl they show up as valid to.

http://severinghaus.org/projects/icv/
Filename: calendar-jelle.ics
Size: 	  25971 bytes
Congratulations; your calendar validated!
You need to log in before you can comment on or make changes to this bug.