Need cursor images for 64 bit OS X

RESOLVED DUPLICATE of bug 489734

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 489734
9 years ago
9 years ago

People

(Reporter: faaborg, Unassigned)

Tracking

Trunk
x86_64
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [icon-3.2])

Requested received in email from Josh Aas:

I'd like to request some images for Mac OS X cursors. 64-bit Mac OS X does not provide a few cursors that Gecko exposes (see Mozilla bug 464315) and thus in order to make 64-bit Mac OS X builds we'll need to use custom images for those cursors. I plan to file a bug on this, I'd like to hear what you have to say about this before I do so since I suspect the bug will be assigned to you.

The custom cursor images we already use can be found here:

http://mxr.mozilla.org/mozilla-central/source/widget/src/cocoa/cursors/

The cursors we'll need (single, non-animated) images for are:

eCursor_copy: The cursor identified by this constant is typically used when the cursor is over a location where a drag action would initiate a copy.

eCursor_alias: The cursor identified by this constant is typically used when the cursor is over a location where a drag action would create an alias or link.

eCursor_context_menu: The cursor identified by this constant is typically used when the Control key is being pressed and the cursor is over a location where a contextual menu can be activated.

eCursor_no_drop, eCursor_not_allowed: The cursor identified by this constant is typically used to indicate that the current action is not allowed. For example, you could use this cursor to indicate that an object being dragged cannot be dropped at the current mouse position.
(Reporter)

Updated

9 years ago
Whiteboard: [icon-3.2]

Comment 1

9 years ago
Essentially says the same thing as 489734, which has a test case, so resolving this one to that.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 489734
You need to log in before you can comment on or make changes to this bug.