Illegal instruction in Windows Mobile Emulator

RESOLVED WORKSFORME

Status

()

Core
Graphics
RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: ndaversa, Assigned: jrmuizel)

Tracking

Trunk
ARM
Windows Mobile 6 Professional
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b2) Gecko/20081201 Firefox/3.1b2 (.NET CLR 3.5.30729)
Build Identifier: 

armv6 instructions are being called on the armv4 emulator causing....

AKY=00002001 PC=791385f8(xul.dll+0x010585f8) RA=00000002(???+0x00000002) BVA=1d231488 FSR=00000405
Unhandled exception at 0x791385f8 in xulrunner.exe: 0xC000001D: Illegal Instruction.

791385F8  uxtb16      r6, r4 

Reproducible: Always
(Reporter)

Updated

9 years ago
OS: Other → Windows Mobile 6 Professional
Hardware: Other → ARM
(Reporter)

Comment 1

9 years ago
It seems the problem is in...

http://mxr.mozilla.org/mozilla-central/source/gfx/cairo/libpixman/src/pixman-pict.c
lines 2031 and 2032 seem to be corrupted resulting in armv6 code attempting to run on the emulator (armv4)
(Reporter)

Updated

9 years ago
Component: General → GFX: Thebes
Product: Fennec → Core

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 478159
This is different than bug 478159, how ever it does block it.
Blocks: 478159
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
I filed a new bug 481138 to suppress repetition of illegal instruction message.
QA Contact: general → thebes
Does this still happen?  The lines mentioned above look correct to me, as does the rest of the detection code now.

Also, the WinCE paths will probably want something like http://hg.mozilla.org/releases/mozilla-1.9.2/rev/be6c505a2003 to suppress reporting the illegal instructions to the debugger when we try to execute them.

Assigning to jeff to do as he wishes!
Assignee: nobody → jmuizelaar
this works for me
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.