Firefox hangs then crashes [@ GCGraphBuilder::AddNode]

RESOLVED DUPLICATE of bug 502687

Status

()

RESOLVED DUPLICATE of bug 502687
10 years ago
9 years ago

People

(Reporter: alex, Unassigned)

Tracking

3.0 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_6; en-us) AppleWebKit/525.27.1 (KHTML, like Gecko) Version/3.2.1 Safari/525.27.1
Build Identifier: 

With lots of tabs open, Firefox eventually hangs for a while, then crashes.

Reproducible: Sometimes

Steps to Reproduce:
One window, ~140 tabs open. Box was not out of RAM. Some tabs have Flash in them (such as paused YouTube videos). Firefox was the foreground application this time.
Actual Results:  
Crashed.

Expected Results:  
Not crashed.

See attachments; sample taken while Firefox was hung/beachballed (beach ball, colour wheel, color wheel, whatever).
(Reporter)

Comment 1

10 years ago
Created attachment 365115 [details]
Sample taken with Activity Monitor while hung
(Reporter)

Comment 2

10 years ago
Created attachment 365117 [details]
Raw Dump from Firefox Crash Reporter
(Reporter)

Comment 3

10 years ago
Crashed @ GCGraphBuilder::AddNode(void*, nsCycleCollectionParticipant*)
Version: unspecified → 3.0 Branch
(Reporter)

Comment 4

10 years ago
Mar  2 22:25:04 machine-name [0x0-0x14f14f].org.mozilla.firefox[0]: *** error: can't allocate region
Mar  2 22:25:04 machine-name [0x0-0x14f14f].org.mozilla.firefox[0]: *** set a breakpoint in malloc_error_break to debug
Mar  2 22:25:04 machine-name [0x0-0x14f14f].org.mozilla.firefox[0]: firefox-bin(3704,0xa012a720) malloc: *** mmap(size=8388608) failed (error code=12)
(Reporter)

Comment 5

10 years ago
Created attachment 365122 [details]
System Profile (redacted)
(Reporter)

Comment 6

10 years ago
/usr/include/sys/errno.h :
#define	ENOMEM		12		/* Cannot allocate memory */
(Reporter)

Comment 7

10 years ago
Firefox version is 3.0.6 on Mac OS X 10.5.6 (9G55).
Please type about:crashes in the URL bar and paste the breakpad crash ID in the bug. Thanks.
(Reporter)

Comment 9

10 years ago
Crash ID is 03231778-bc66-4085-aef0-fc82f2090302

Updated

9 years ago
Attachment #365122 - Attachment mime type: text/plain → text/plain;charset=UTF-16

Comment 10

9 years ago
bp-03231778-bc66-4085-aef0-fc82f2090302 shows this crashing at precisely the point where I'd expect bug 502687 to occur, and your system profile shows evidence that Firefox ran out of virtual memory.  So this is a dup of bug 502687, which was fixed on trunk last month.

But note that when Firefox is out of memory, it's likely to crash for one reason or another.  You're better off tackling the memory use issue (by helping us find leak bugs or memory use bugs, or by keeping fewer tabs open) than the individual crashes that result.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Summary: Firefox hangs then crashes → Firefox hangs then crashes [@ GCGraphBuilder::AddNode]
Duplicate of bug: 502687
You need to log in before you can comment on or make changes to this bug.