Username modification not taken in account

RESOLVED WORKSFORME

Status

Thunderbird
Account Manager
--
major
RESOLVED WORKSFORME
9 years ago
8 years ago

People

(Reporter: Jean-Baptiste Perriot, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.0.6) Gecko/2009011913 Firefox/3.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090223 Thunderbird/3.0b2

If you create an IMAP account with a wrong username (i made a mistake on .fr which became .tr) and then make the correction it is taken in account in the UI but not in the url passed to the server : 


Reproducible: Always

Steps to Reproduce:
1. Create an imap account
2. make a mistake in the username
3. validate
4. edit the account, correct the user name
5. try to read your mails : can't login.
Actual Results:  
Login to server [URL] failed



from the logs after correcting the username (which is now good in the UI and not present in the password manager) :

4780[417c7c0]: 2f1c800:ns0.ovh.net:NA:ProcessCurrentURL:imap://#####%25###%2Etr@ns0.ovh.net:143/select%3E%5EINBOX: = currentUrl
> 4. edit the account, correct the user name

Edited prefs.js manually or modified via "Config Editor"?
Or via "Server Settings" UI?

If result of manual editing, user error.
If via UI, same as Bug 274027 isn't it? Read Bug 131176 Comment #2, please.

See also Bug 131176 Comment #2 & Bug 303542 for possible problem after hostname/username change via UI.
(Reporter)

Comment 2

9 years ago
I made the modification via the UI (server settings). But did not looked at the prefs.js.
so finaly the realusername is fine. I though it did not update the username used for login because I had a 'login failed message'. I made some new tests today, and I do not understand why but it is finally working fine. Maybe something was wrong on the server side (the strange point is that outlook was working fine)
I'm not a big fan of this design decision myself, but the IMAP URLs use the original username even though the server login code uses the real username.

Your login failure could have just been a transient server error (too many connections, perhaps?) or a mistyped password. IMAP really fails at distinguishing between various forms of login failure.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.