drop a folder over browser hit reload and mozilla gives an exception error

VERIFIED WORKSFORME

Status

P3
normal
VERIFIED WORKSFORME
19 years ago
14 years ago

People

(Reporter: airipsny, Assigned: mikepinkerton)

Tracking

({crash})

Trunk
x86
Windows NT
crash

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [NEED INFO], URL)

(Reporter)

Description

19 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; m18) Gecko/20000808
BuildID:    2000080808

mozilla returned an exception error after I hit reload and then it closed all of
its windows and exited


Reproducible: Always
Steps to Reproduce:
1.start mozilla
2.open file explorer and drag a file over mozilla window
3.hit the reload button

Actual Results:  first before hitting reload i saw a blank gray screen
then after hitting reload mozilla returned an exception error it looked like it
was trying to write to unallocated memory


Expected Results:   expected to see a listing of files in that directory..
expected reload to refresh that screen

i tried this a few times.could just be the build because its the latest one

Comment 1

19 years ago
Confirmed.  D&D a directory, and it crashes.  build 2000080808 on Win98.
I was using F: which is a mapped drive, if that matters.

Comment 2

19 years ago
over to xpapps
Assignee: asa → don
Status: UNCONFIRMED → NEW
Component: Browser-General → XP Apps
Ever confirmed: true
QA Contact: doronr → sairuh
drag'n'drop...eli/pink...?
QA Contact: sairuh → elig
Keywords: crash

Comment 4

18 years ago
nav triage team: [NEED INFO]
if you don't press reload, will you get a crash sooner or later anyway because 
you click back, fwd, etc?

reassigning QA: claudius, eng pinkerton
Assignee: don → pinkerton
Keywords: nsbeta3
QA Contact: elig → claudius
Whiteboard: [NEED INFO]
(Assignee)

Comment 5

18 years ago
this works for me with a build from 8/17. note that hitting reload doesn't reload 
the page, but that sure isn't my problem.
(Reporter)

Comment 6

18 years ago
upgraded to 48125 build..   crash seems to be fixed.. well i managed to get an 
exception error twice with hitting reload.. but its not reproducible anymore
I'll try the newest build and see what happens..   hmm what i remember when i 
crashed it the two times was mozilla didn't look like it had loaded the 
directory.. or was currently processing it.. well if that helps any  (it did 
crash when i hit stop one of those two times..  instead of reload)  but overall 
the problem seems gone
(Assignee)

Comment 7

18 years ago
ok then
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
mass-verifying WorksForMe bugs which haven't changed since 2001.12.31.

set your search string in mail to "EmperorLondoMollari" to filter out these
messages.
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.