Offline -> Preferences -> Signin, and nothing happens

RESOLVED FIXED in 0.3

Status

RESOLVED FIXED
10 years ago
9 years ago

People

(Reporter: martin, Unassigned)

Tracking

unspecified
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2) Gecko/20081201 Firefox/3.1b2 (.NET CLR 3.5.30729)
Build Identifier: 

Just got into the beta, and this is my first time running FF3.1 Beta after installing the Weave addon. I notice that when I hit the bottom right hand corner "Offline" button and choose "Preferences," the "Sign In" button in the dialog doesn't do anything. Choosing "Sign In" directly from the Weave area in the bottom right does work, still.

See "additional information" for the error console output.

Reproducible: Always

Steps to Reproduce:
1. Install FF3.1 Beta, latest Weave addon
2. Right click on the bottom-right corner weave button
3. Choose preferences, then click the "Sign In" button
Actual Results:  
Nothing happens

Expected Results:  
Shown a prompt to sign in

The following appears in the Error Console:
Error: uncaught exception: [Exception... "Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIPrefBranch.getCharPref]"  nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame :: chrome://weave/content/preferences.js :: WeavePrefs_doSignOn :: line 114"  data: no]
(Reporter)

Updated

10 years ago
Version: unspecified → 0.2

Comment 1

10 years ago
Indeed, that will not work the first time.  Fix will be committed soon, will go out in the next version.
Blocks: 468689
Status: UNCONFIRMED → NEW
Ever confirmed: true
Target Milestone: -- → 0.3

Comment 2

10 years ago
version -> 0.3
(confusing, I know, 0.2.90+ are all pre-releases for 0.3)
OS: Windows XP → All
Hardware: x86 → All
Version: 0.2 → 0.3
(Reporter)

Comment 3

10 years ago
Hah, thanks for the tip. BTW I'm liking everything so far -- thanks for all your hard work :)

Comment 4

10 years ago
Thanks!

http://hg.mozilla.org/labs/weave/rev/44d84989dfcd

And this went out in 0.2.109.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Updated

9 years ago
Component: Weave → General
Product: Mozilla Labs → Weave
Version: 0.3 → unspecified
QA Contact: weave → general
You need to log in before you can comment on or make changes to this bug.