Sessionrestore should ask after first crash and not after second one by default

RESOLVED WONTFIX

Status

enhancement
RESOLVED WONTFIX
10 years ago
9 years ago

People

(Reporter: losepete, Unassigned)

Tracking

(Blocks 1 bug)

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

10 years ago
User-Agent:       Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.9.1b3pre) Gecko/20090221 SeaMonkey/2.0b1pre
Build Identifier: Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.9.1b3pre) Gecko/20090221 SeaMonkey/2.0b1pre

I had seamonkey crash.

On restart the same tabs tried to load automatically - no "do you want to take a chance and reload the previous session of which at least 1 webpage was causing problems?" - seamonkey went straight into trying to load those pages.

As 1 or more of those pages had caused a problem and I was not really concerned if I ever saw those pages again I was not very impressed with this "default" action.

I found a discussion about "about:restoresession" - see Bug 36810 and joined in.

This enabled me to change the ridiculous default setting that produces the unwanted behaviour documented above. I changed the setting browser.sessionstore.max_resumed_crashes to 0 - which I think should be the "default" setting - and can now decide whether to try and reload a previous session or not on the 1st restart Rather than having seamonkey attempt to restore against my wishes.


Why is this setting "defaulted" to 1?


Do you think no-one will notice the browser crashed when it tries to automatically resume the previous session? - all those webages loading at once are a bit of a giveaway.


Please default this setting to 0 and give the user the immediate choice as to whether to restore all/part of the previous session. Thank You.


Reproducible: Always

Steps to Reproduce:
1. Crash browser
2. Restart browser
3. about:restoresession is not displayed using the "default" setting for browser.sessionstore.max_resumed_crashes

If the browser crashes again when trying to restore the previous session then about:restoresession will be displayed.
Actual Results:  
Automatic attempt to restore previous crashed session.

Expected Results:  
Automatic attempt to restore previous crashed session.

Havinmg set the Preference browser.sessionstore.max_resumed_crashes to 0 Seamonkey now displays about:sessionrestore on 1st restart after a crash - a much more user friendly setting as it lets the user decide.

Updated

10 years ago
OS: OS/2 → All
Hardware: x86 → All
Version: unspecified → Trunk

Updated

10 years ago
OS: All → OS/2
Hardware: All → x86
Summary: about:restoresession "default" badly configured → about:sessionrestore "default" badly configured

Comment 1

10 years ago
Could this be an OS/2 specific problem? Because on my Linux setup I very well get the restore page after a crash, even with max_resumed_crashes set to the default of 1.
Component: Startup & Profiles → Session Restore
QA Contact: profile-manager → session.restore

Comment 2

10 years ago
There are number of crashed not related to browser. SeaMonkey is a suite of internet applications and they can crash too. So if your mailnews or chatzilla or even some plugin in browser crashes, you'll get your tabs restored without any annoying questions. The setting are ported (say copy/pasted) from Firefox and no special investigation was done to understand why they selected default value 1, even when they have less reasons to do that. IMHO this should be WONTFIX.

Comment 3

10 years ago
(In reply to comment #0)
> Please default this setting to 0 and give the user the immediate 
> choice as to whether to restore all/part of the previous session. 

Vote for this bug.


(In reply to comment #1)
> ... Because on my Linux setup I very well get the restore page 
> after a crash, even with max_resumed_crashes set to the default of 1.

On Win XP I got a mysterious loop of crashes while starting and needed to change prefs.js. I'm going to file a bug to get this setting in the visual user interface.
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: OS/2 → All
Summary: about:sessionrestore "default" badly configured → Sessionrestore should ask after first crash and not after second one by default

Updated

10 years ago
Blocks: 522466

Comment 4

9 years ago
resolving per comment #2 - the SeaMonkey owner of this feature has spoken - and the project management agrees.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.