horizontal rules don't center correctly over a floating table

CLOSED FIXED

Status

()

Core
Layout
P3
normal
CLOSED FIXED
18 years ago
10 years ago

People

(Reporter: TimMaroney, Assigned: buster)

Tracking

({testcase})

Trunk
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: needs verification on Mac, Linux, Win9x, URL)

Attachments

(1 attachment)

173 bytes, text/html
Details
(Reporter)

Description

18 years ago
Take a look at http://maroney.org in M17. Note that the horizontal rule in 
the main text is centered with respect to the overall page frame rather than 
within its current text run, which is sitting to the right of a floating table. As 
a result, the rule cuts into the table rather than staying within the text in 
which it is embedded. This is a pretty major eyesore.

(Note: Mac M17 was used; never mind what the autofill says. Why is it 
assuming that I was using bugzilla from the browser where I reproduced 
the problem, anyway?)

Comment 1

18 years ago
setting bug status to new
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

18 years ago
*** Bug 48144 has been marked as a duplicate of this bug. ***

Comment 3

18 years ago
Re-assigning 6 bugs from Clayton's list to Harish for further triage.
Assignee: clayton → harishd

Comment 4

18 years ago
Triaging Clayton's list:
------------------------

I see the problem too.

Looks like a block layout problem. Reassigning bug to waterson and ccing 
attinasi and myself.
Assignee: harishd → waterson

Comment 5

18 years ago
Created attachment 13061 [details]
Testcase

Comment 6

18 years ago
I can reproduce this bug on Windows 98 SE, using Build #2000081108, therefore 
I've changed the Platform and OS to "All".

Also, I's seems to me that the problem is that the HRs with is correctly 
calculated, but it is centered without taking into account the floating 
element. Than again, I'm not a coder :)
Keywords: testcase
OS: Mac System 9.0 → All
Hardware: Macintosh → All

Comment 7

18 years ago
buster, this is a float bug, which you will probably be able to fix much more
quickly than I.
Assignee: waterson → buster

Comment 8

18 years ago
massive update for QA contact.
QA Contact: petersen → lorca
(Assignee)

Comment 9

18 years ago
probably a dup of 18754.  could somebody verify that this is working, and
assuming it is we'll mark it a dup.
Status: NEW → ASSIGNED
Yep, WORKSFORME with Windows 2000 commercial build 2000091212. (I prefer to
mark it works for me, it will get better cross-platform verification that way.)
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Keywords: verifyme
Resolution: --- → WORKSFORME
Whiteboard: needs verification on Mac, Linux, Win9x
Reassigning QA Contact for all open and unverified bugs previously under Lorca's
care to Gerardo as per phone conversation this morning.
QA Contact: lorca → gerardok

Comment 12

18 years ago
qa contact updated.
QA Contact: gerardok → bsharma

Comment 13

17 years ago
Verified on:
build: 2001-04-09-11-Mtrunk
Platform: Win 2000

The url and the test case loads fine.
Status: RESOLVED → VERIFIED
(Reporter)

Updated

17 years ago
Status: VERIFIED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Comment 14

17 years ago
Verified fixed on 0.8.1 on Mac. Changing resolution to fixed.
(Reporter)

Comment 15

17 years ago
...
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago17 years ago
Resolution: --- → FIXED
(Reporter)

Comment 16

17 years ago
...
Status: RESOLVED → CLOSED
SPAM. HTML Element component is deprecated, changing to Layout component. See
bug 88132 for details.
Come on Bugzilla, you can do it...
Component: HTML Element → Layout

Updated

10 years ago
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.