Fehler: Error parsing XML streamReferenceError: getTimezoneService is not defined

VERIFIED FIXED in 1.0b1

Status

defect
VERIFIED FIXED
10 years ago
8 years ago

People

(Reporter: ts.bugzilla, Assigned: Fallen)

Tracking

unspecified
1.0b1

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3pre) Gecko/20090304 Firefox/3.0.5
Build Identifier: 

Using Thunderbird 3.0b2 and Lightning 20090304 nightly build one of my Google Calendars doesn't show any events. Many occurrences of the error

Fehler: Error parsing XML streamReferenceError: getTimezoneService is not defined

appear in the error console.
The calendar is not owned by me, but shared privately, for w.i.w.

Reproducible: Always
Do you access your calendar via CalDAV protocol or Provider for Google Calendar extension? In the latter case: Do you use the most recent nightly build of the extension?

Could you copy and paste the complete message from Tools > Error Console that contains the source file and line number information?
(Reporter)

Comment 2

10 years ago
(In reply to comment #1)
> Do you access your calendar via CalDAV protocol or Provider for Google Calendar
> extension?

I access the calendar via GData Provider. (side note: it would be awfully nice to have a way to lookup/configure the provider for an existing calendar, is there a bug for that?)

> In the latter case: Do you use the most recent nightly build of the extension?

Yes, the provider extension is kept up-to-date using the nightly updater extension like the Lightning build.

> Could you copy and paste the complete message from Tools > Error Console that
> contains the source file and line number information?

That's the fun part, that is the whole error message. No file and line number are given.
Posted patch Fix - v1 β€” β€” Splinter Review
I haven't been able to reproduce the error, but this should fix all problems with the timezone service getter not being found. It also fixes the strict warning caused by bug 329570 and unanonymizes some functions there.
Assignee: nobody → philipp
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #365632 - Flags: review?(ssitter)

Comment 4

10 years ago
Unfortunately I don't know how to use the fix.

I get the same error with the latest Sunbird nightly (Google provider) and I can reproduce it.

Download the ical from here: http://www.cs.univie.ac.at/teaching_description.php?tid=10171
Import it with Google Calendar and as a result Sunbird doesn't show any events anymore. 
Instead it creates the XML error message.
When removing the imported events, the error message in Sunbird disappears again and all events are back.

When I try to import the .ics directly into Sunbird I get following error:

[Exception... "Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIScriptableUnicodeConverter.convertFromByteArray]"  nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame :: file:///D:/Programme/sunbird/modules/calUtils.jsm -> file:///D:/Programme/sunbird/calendar-js/calIcsParser.js :: ip_parseFromStream :: line 223"  data: no]
Comment on attachment 365632 [details] [diff] [review]
Fix - v1

> /* Returns a clean new calIEvent */
>-function createEvent() {
>-    return Components.classes["@mozilla.org/calendar/event;1"].
>-           createInstance(Components.interfaces.calIEvent);
>+function createEvent(aIcalString) {
> }

r=ssitter but I'd like you to update the method description to the changed interface.
Attachment #365632 - Flags: review?(ssitter) → review+
Done, also added the same parameter+description for createTodo().

Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/adf66ec7ddde>

-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.0
(Reporter)

Comment 7

10 years ago
Fantastic! Using the tinderbox build from
ftp://ftp.mozilla.org/pub/mozilla.org/calendar/lightning/tinderbox-builds/comm-central/win32-xpi-win32/1236576291/
the errors are gone and events from the Google Calendar show up once again.
(Assignee)

Updated

10 years ago
Status: RESOLVED → VERIFIED
These bugs are likely targeted at Lightning 1.0b1, not Lightning 1.0. If this change was done in error, please adjust the target milestone to its correct value. To filter on this bugspam, you can use "lightning-10-target-move".
Target Milestone: 1.0 → 1.0b1
You need to log in before you can comment on or make changes to this bug.