FF hangs when dragging/moving complex bookmark folders

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
10 years ago
8 years ago

People

(Reporter: rufusl2001, Unassigned)

Tracking

3.5 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [TSnappiness])

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b2) Gecko/20081201 Firefox/3.1b2
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b2) Gecko/20081201 Firefox/3.1b2

In OrganizeBookmarks, when dragging moderate sized (5-10 entries) folders 4 or 5 at a time into another folder (from the right frame to the tree in the left frame), after 2 or 3 drags (and apparently completing the move correctly) the next drag/drop hangs FF. 

Although the cursor will move, it remains the "drag cursor", not the system cursor, at all locations on the screen, even over the desktop. Keyboard and mouse will not perform any functions - ie. can't switch to other running apps, cannot close windows. Under my Linux distro ctl-alt-Fn will switch to another terminal where "killing" FF frees up the system. 

I have about 20 folders in the "Toolbar Menu" and about 50 "Unsorted bookmarks" under the main menu. 6-10 folders have subfolders and of those 5-8 have lower level subfolders. Most folders contain between 3 and 20 bookmarks while some have up to 50.

Because this problem closes out the whole system it may cause non-technical users to do a hard reboot and possibly lose data from other open apps. This type of activity is typical of housekeeping after one accrues new bookmarks over time.

Reproducible: Always

Steps to Reproduce:
1.Install/create a moderate sized bookmarks file.
2.Open "OrganizeBookmarks" window; select 3 to 5 folder on the right (ctl-leftclick) and drag the selection into a folder on the tree at left.
3.Repeat this several times, starting the next action immediately when the previous complete.
Actual Results:  
The "drag shadow" of the selected folders/files freezes; the cursor remains the "drag cursor" although it will move about the screen; you cannot close FF nor switch to other apps using either the keyboard or the mouse.

Expected Results:  
Normal drag/drop. If FF binds up, it should not lock you out of the system and the other apps.

Running the beta from a user directory;default themes. Adblock+ is enabled; in the past year using FF 3.05 with minimal bkmark editing I have experienced no problems with Adblock+. I _did_ experience problems with FF 3.05 bkmarks editing as soon as I started housekeeping the bookmark file. The beta handles bookmark sorting much faster and actually saves the changes made to the file (as opposed to FF 3.05 losing all changes); some drag/drop moves did work in the beta.
(Reporter)

Updated

10 years ago
Version: unspecified → 3.1 Branch
(Reporter)

Comment 1

10 years ago
Edit above in paragraph 3 line 1: "Toolbar Menu" s/b "Bookmark Menu"
(Reporter)

Comment 2

10 years ago
OK. I continued using editing the bookmark file and found that using cut/paste (avoiding drag/drop w/it's window management issues) appears to work; there occasionally appear a warning pop-up about a run-on script but this is manageable. I don't know why this script warning pop-up doesn't appear when using drag/drop, but I believe that it does NOT (ie. the hangs that I experienced using drag/drop continued far past the time interval that the warning pop-up should have appeared). Possibly there is something in the window management or X server hand-off that loses the pop-up. 

HOWEVER: The editing "performance" of the bookmark file is ... glacial. I found that I had one folder containing ancient Sage links that had more than 3000 links in 50 or 60 folders. When I cut/pasted this folder it took about 5 minutes with 6 pop-ups to "cut" it; it then took about 12 minutes with about 15 pop-ups to paste it. The file manager shows places.sqlite at 1.8MB. 

This is a problem for anybody that does extensive internet research and wants to save their efforts.

Rufus

Updated

9 years ago
Whiteboard: [TSnappiness]
this could be a dupe but no reasons to stay UNCO
Summary: FF hangs when dragging bookmark folders → FF hangs when dragging/moving complex bookmark folders

Updated

9 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
couldhave been partially covered by bug 490742

Updated

9 years ago
Duplicate of this bug: 529944

Comment 6

9 years ago
Hi all. I filled Bug #529944, and since it's marked as a duplicate of this one, I think I should add the additional info I found here. For me, it's only Firefox that hangs --for several minutes-- but the rest of the OS is responsive. I discovered that Fx also hangs when deleting a folder in the library. In both types of hangs (copying & deleting) the Task Manager > Applications, shows 2 instances of the Library (!) and 1 instance of Firefox, all 3 "Not responding". When Firefox comes back to normal, just 1 instance of the Library and 1 instance of Firefox are shown active (as expected).

I've tried in Safe Mode with the same results. Hope this helps.

Comment 7

9 years ago
Carlos: did you also at one point have the Sage extension installed?

Comment 8

9 years ago
(In reply to comment #7)
> Carlos: did you also at one point have the Sage extension installed?

Touché. Bingo. I had the original Sage 1.4.3 installed. Right now I have Sage Too 2.0.0 installed.
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
I think this is much better in Firefox 4, for future we need more specific examples/test cases to debug the single cases.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.