cannot close the last remaining tab

RESOLVED INVALID

Status

()

Firefox
Tabbed Browser
--
enhancement
RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: Ryan Li, Unassigned)

Tracking

unspecified
Points:
---
Bug Flags:
blocking-firefox3.5 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20090304 Minefield/3.2a1pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20090304 Minefield/3.2a1pre

When there's only one tab left, I cannot close it and return to a blank page, as firefox 3.0 does.

Reproducible: Always

Steps to Reproduce:
1. Open any web page in a tab.
2. Try to close it
Actual Results:  
Nothing happens, and the button is gray, firefox prevents you from closing the last one!

Expected Results:  
Close the tab as it used to do, or provide an option for user to choose which way firefox should behave.

Comment 1

9 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090304 Minefield/3.2a1pre
Middleclicking the last tab replaces it with a blank page for me
(Reporter)

Updated

9 years ago
Summary: cannot close the last tab → cannot close the last remaining tab
(Reporter)

Comment 2

9 years ago
@Mardeg:

Maybe this behaviour is Linux-only?
Can anyone confirm this?
Windows Vista, latest trunk, new profile: 
When I middle click on the last tab, nothing happens.
With the old setting still present in my default profile I get a blank tab.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: x86 → All
Flags: blocking-firefox3.1?
Maybe caused by Bug 456382? Will try to check later.

Comment 5

9 years ago
I get no button with one tab open, this is the new expected behavior. (I recall beltzner talking about it)

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20090305 Minefield/3.2a1pre
(Reporter)

Comment 6

9 years ago
But I think that should be a choice? Since I am quite used to the old behaviour.
This is working as expected on Linux, OSX and Windows, fwiw:

 - the close button isn't shown on the last tab
 - the middle mouse button doesn't close the last tab
 - ctrl+w on the last tab closes the entire window

(see bug 392870 and dependencies such as bug 348031 and bug 456405 for original rationale as to why we do this)

(In reply to comment #6)
> But I think that should be a choice? Since I am quite used to the old
> behaviour.

See bug 455852 - browser.tabs.closeWindowWithLastTab exists for this purpose.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Flags: blocking-firefox3.1? → blocking-firefox3.1-
Resolution: --- → INVALID

Comment 8

9 years ago
I am using the old behaviour (pre 2) with browser.tabs.closeButtons set to 3, if i use it on the last tab, the whole windows closes, too.
Stefan, if you think this is a bug (I think it is because it is unexpected given the recent change), please file a new bug.
You need to log in before you can comment on or make changes to this bug.