Closed Bug 481568 Opened 11 years ago Closed 11 years ago

Crash on shutdown when dragging link over window [@ nsWindow::DragLeaveTimerCallback]

Categories

(Core :: Widget: Gtk, defect, critical)

x86
Linux
defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla1.9.2a1

People

(Reporter: mats, Assigned: mats)

Details

(Keywords: crash, platform-parity)

Crash Data

Attachments

(1 file)

Crash on shutdown when dragging link over window
[@ nsWindow::DragLeaveTimerCallback]

STEPS TO REPRODUCE
1. create many windows with many tabs (in my case 48 windows with several
   hundred tabs total)
2. File -> Quit
3. while the windows disappear (which is very slow) drag a link from
   a different app (thunderbird in my case) over the windows

ACTUAL RESULT
bp-738e1b63-7a3c-4144-b5a3-14a542090304
bp-7708f8d6-b205-48ac-a87a-d5d0d2090304

@0xffffe410	
@0x5	
libc-2.7.so@0x2ccb0	
libstdc++.so.6.0.9@0xbb81f	
libstdc++.so.6.0.9@0xb90a4	
libstdc++.so.6.0.9@0xb90e1	
libstdc++.so.6.0.9@0xb99a4	
nsWindow::DragLeaveTimerCallback	nsAutoPtr.h:980
nsTimerImpl::Fire	xpcom/threads/nsTimerImpl.cpp:428
nsTimerEvent::Run	xpcom/threads/nsTimerImpl.cpp:520
nsThread::ProcessNextEvent	xpcom/threads/nsThread.cpp:510
NS_ProcessNextEvent_P	nsThreadUtils.cpp:230
nsBaseAppShell::Run	widget/src/xpwidgets/nsBaseAppShell.cpp:170
nsAppStartup::Run	toolkit/components/startup/src/nsAppStartup.cpp:192
XRE_main	toolkit/xre/nsAppRunner.cpp:3220
main	browser/app/nsBrowserApp.cpp:156
libc-2.7.so@0x1644f
Taking since I think I know what the problem is...
Assignee: nobody → mats.palmgren
Attached patch Patch rev. 1Splinter Review
1. Cancel() a pending mDragLeaveTimer in nsWindow::Destroy()
2. don't create another mDragLeaveTimer in nsWindow::OnDragLeaveEvent()
   if we already have one pending
3. fix a few compile warnings
Attachment #365949 - Flags: superreview?(roc)
Attachment #365949 - Flags: review?(roc)
Attachment #365949 - Flags: superreview?(roc)
Attachment #365949 - Flags: superreview+
Attachment #365949 - Flags: review?(roc)
Attachment #365949 - Flags: review+
http://hg.mozilla.org/mozilla-central/rev/a6d413f95417

-> FIXED
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.2a1
Crash Signature: [@ nsWindow::DragLeaveTimerCallback]
You need to log in before you can comment on or make changes to this bug.