If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Context menu slow to show when right-clicking

VERIFIED INVALID

Status

()

Firefox
Menus
VERIFIED INVALID
9 years ago
9 years ago

People

(Reporter: George, Unassigned)

Tracking

3.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.6) Gecko/2009011913 Firefox/3.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.6) Gecko/2009011913 Firefox/3.0.6

While I was editing a Wikipedia article I wanted to copy and paste some text. I highlighted the text I wanted to copy and paste from the article, but when I right-clicked it to get the Copy and Paste functions I had to wait quite a while for the thing to popup (like 4 or 5 seconds from when I clicked). 

Reproducible: Always

Steps to Reproduce:
1. Go to http://en.wikipedia.org/wiki/Late_2000s_recession
2. Click "edit this page"
3. Highlight some text in the text box
4. Right-click the highlighted text
Actual Results:  
Appearance of contextual menu is slow

Expected Results:  
Context menu should show up immediately
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.8pre) Gecko/2009022106 GranParadiso/3.0.8pre

WFM with a new profile.
wfm with FF3.0.7 and SM trunk.
Reporter: is your result the same in the Firefox safemode ?
http://support.mozilla.com/en-US/kb/Safe+Mode
(Reporter)

Comment 3

9 years ago
Just tried it in Safe Mode. Yes, I still have to wait for the menu to popup.

It's weird, majority of the time the right-click works fine. But on a few websites (like Wikipedia editing pages) I'm getting this behavior.
Do you have a sidebar enabled in Firefox ?
(Reporter)

Comment 5

9 years ago
No.

Just upgraded from 3.0.6 to 3.0.7, but the behavior is the same.
George, could you run a test with a new profile too? Does it help? See http://support.mozilla.com/en-US/kb/Managing+profiles how to get it. Thanks.
(Reporter)

Comment 7

9 years ago
Yeah, that seemed to have worked.

Why is that?
The profile stores all preferences, user data, addons.
It can be only some settings or history/bookmarks if you are sure that you entered the safemode (and the safemode popup appeared).
(Reporter)

Comment 9

9 years ago
I don't think I entered Safe Mode correctly since I didn't see a popup.

Anyway, after playing with the Add-ons, it seems to be the Text Link extension that's slowing me down. When I disable it the behavior stops.
You have to close Firefox including all open windows (like the downloadmanager) before you can start Firefox in the safemode.

The safemode itself is just Firefox without extensions and third-party Themes and it's used to find issues with addons like this one.

Please notify the Text link Extension author about the issue with his addon.
marking invalid because this is no bug in Firefox itself.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
Btw. this should be solved with the Version 3.0.2009030901 of the addon which has been released two days ago.
Status: RESOLVED → VERIFIED
Version: unspecified → 3.0 Branch
You need to log in before you can comment on or make changes to this bug.