Would like an intelligent prompt for attachments when hitting "Send".

RESOLVED DUPLICATE of bug 244455

Status

Thunderbird
Message Compose Window
--
trivial
RESOLVED DUPLICATE of bug 244455
9 years ago
9 years ago

People

(Reporter: Peva, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.1.4322; .NET CLR 2.0.50727)
Build Identifier: 

How many times have you sent an email intended to have an attachment, but you forgot to attach that attachment(s) before hitting Send (minor embarrassment)?  The simplest enhancement would be for a nag to always popup when you hit send asking if you remembered or intended to include any attachments.  A better one would search for the string "attach" in the email (working under the assumption that you would have mentioned an attachment (using the word 'attached' or 'attachment' or 'attachments') somewhere in your email if you were likely to have intended on including an attachment, and if that strung appears in your outgoing message, then popup the nag/prompt.  This prompt could be user enabled and disabled with a checkbox in Tools > Options or Account Settings.

Reproducible: Always

Steps to Reproduce:
1. Compose an outgoing email with the intention of including an attachment.
2. Forget to attach attachment(s).
3. Hit 'Send'
Actual Results:  
Email goes out without attachment - you look (choose one): stupid/unprofessional/not super-human/senile.

Expected Results:  
Popped up a prompt for an attachment something like "Did you remember/intend to include any attachments?".  (This is *not* the same as a Word prompt saying "It looks like you are intending to write a suicide note.  Do you need assistance with this task?")

This is obviously not an urgent or must-have need.  This might be a handy Add-on/Extension.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 244455
You need to log in before you can comment on or make changes to this bug.