Closed Bug 481674 Opened 11 years ago Closed 11 years ago

Images attached to emails when accessing AOL mail on the web fail to display - get broken box icon instead.

Categories

(Core :: General, defect, major)

x86
Windows XP
defect
Not set
major

Tracking

()

VERIFIED DUPLICATE of bug 482659

People

(Reporter: noodnick9, Unassigned)

References

()

Details

Attachments

(5 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.7) Gecko/2009021910 Firefox/3.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.7) Gecko/2009021910 Firefox/3.0.7

When accessing AOL e-mail via Firefox, attached images used to display directly below the e-mail text.  Since upgrading to Firefox 3.0.7, images no longer display, but an icon of a broken page appears instead.  Using IE, the attached image continues to appear properly.

Reproducible: Always

Steps to Reproduce:
1.Go to www.aol.com
2.Sign in to a valid e-mail account
3.Read an e-mail that contains a jpg attchment
4.See the non-display of the image
Actual Results:  
A display of an icon of a broken page, followed by a "Download" button, but the .jpg should appear instead of the icon.

Expected Results:  
The actual attached image should be displayed, followed by a Download button.

No other special info.  I merely upgraded from 3.0.6 to 3.0.7
Product: Firefox → Core
QA Contact: general → general
>2.Sign in to a valid e-mail account

This is a thing that stops us from looking at it.
Please post the image path used for the image. You can get it if you right
click on the broken image and select properties.

And please do the same with IE and post the URL from IE.
Here's an example of what did not work using Firefox:
/41757/aol/en-us/mail/get-attachment.aspx?uid=1.23124996&folder=NewMail&partId=4
size= 24x24 pixels

Here's the same jpg in IE:
get-attachment.aspx?uid=1.23124996&folder=OldMail&partId=4
Address: http://webmail.aol.com/41757/aol/en-us/mail/get-attachment.aspx?
size= 275x206 pixels
This is what I see in Firefox.

I will be sending 4 attachments: how the "image" appears in an e-mail as displayed by IE and by Firefox.
I'll also send the Properties obtained by right clicking on the "image" in IE & Firefox.
This is what I see in IE.

I will be sending 4 attachments: how the "image" appears in an e-mail as displayed by IE and by Firefox.
I'll also send the Properties obtained by right clicking on the "image" in IE & Firefox.
This is the result of displaying Properties of the "image" in Firefox.

I will be sending 4 attachments: how the "image" appears in an e-mail as displayed by IE and by Firefox.
I'll also send the Properties obtained by right clicking on the "image" in IE & Firefox.
These are the Properties obtained by right clicking on the image in IE.

I will be sending 4 attachments: how the "image" appears in an e-mail as displayed by IE and by Firefox.
I'll also send the Properties obtained by right clicking on the "image" in IE & Firefox.
Please select a text block in the email, starting directly above the image ("1 attachment") through the image with text after the image (the attachment name( and you right click with this selection and select view source.
Now copy the source and attach it here.

Thanks
Page source of the page that does not display a jpg attachment, being submitted by Bugzilla request.  I am also attaching a text file of the same source.
============================================================================

<html><head>

</head><body onload="parent.dijit.byId('displayMessage').onBodyLoaded()" class="AOLWebSuite" style="border: 0px none ; background-color: white; font-family: Arial,sans-serif; font-size: 10pt;">


<div id="AOLMsgPart_3_6980d78f-3a7a-4a89-9662-c495193ad1b6">

<font face="Arial, Helvetica, sans-serif">This is sample text.&nbsp; I will also attach one jpg file.<br>
<br>
</font><div id="MAILCIADA037-5c3f49b2ac9525a" class="aol_ad_footer"><br><font style="color: black; font-family: arial,san-serif; font-style: normal; font-variant: normal; font-weight: normal; font-size: 10pt; line-height: normal; font-size-adjust: none; font-stretch: normal; -x-system-font: none;"> <hr style="margin-top: 10px;">Access 350+ FREE radio stations anytime from anywhere on the web. <a target="_blank" href="http://toolbar.aol.com/aolradio/download.html?ncid=emlweusdown00000035">Get the Radio Toolbar</a>!</font> </div>

</div> <!-- end of AOLMsgPart_3_6980d78f-3a7a-4a89-9662-c495193ad1b6 -->

<br><div id="AOLImageAttachmentHeader" style="border: 1px solid rgb(125, 168, 212); background: rgb(249, 249, 249) none repeat scroll 0% 0%; font-family: arial; font-style: normal; font-variant: normal; font-weight: normal; font-size: 11px; line-height: normal; font-size-adjust: none; font-stretch: normal; -x-system-font: none; -moz-background-clip: -moz-initial; -moz-background-origin: -moz-initial; -moz-background-inline-policy: -moz-initial;"><div style="padding: 3px; background: rgb(181, 221, 250) none repeat scroll 0% 0%; font-family: arial; font-style: normal; font-variant: normal; font-weight: normal; font-size: 11px; line-height: normal; font-size-adjust: none; font-stretch: normal; -x-system-font: none; -moz-background-clip: -moz-initial; -moz-background-origin: -moz-initial; -moz-background-inline-policy: -moz-initial;">&nbsp;&nbsp;1 Attached Images</div></div>


<div id="AOLMsgImgInlineRenderPart_4_6980d78f-3a7a-4a89-9662-c495193ad1b6" style="margin: 10px;">

<a href="/41757/aol/en-us/mail/get-attachment.aspx?uid=1.21125773&amp;folder=Inbox&amp;partId=4" target="_blank"><img style="border: 1px solid rgb(218, 218, 214); visibility: visible; cursor: pointer; margin-bottom: 30px;" filename="Pict0032z.JPG" partid="4" class="AOLAttachedImage" src="/41757/aol/en-us/mail/get-attachment.aspx?uid=1.21125773&amp;folder=Inbox&amp;partId=4"><br>

</a></div> <!-- end of AOLMsgImgInlineRenderPart_4_6980d78f-3a7a-4a89-9662-c495193ad1b6 -->

<style>.AOLWebSuite .AOLPicturesFullSizeLink { height: 1px; width: 1px; overflow: hidden; } .AOLWebSuite a {color:blue; text-decoration: underline; cursor: pointer} .AOLWebSuite a.hsSig {cursor: default}</style><link rel="stylesheet" type="text/css" href="http://o.aolcdn.com/cdn.webmail.aol.com/41757/css/microformat.css"><div class="pictureViewControl" style="position: absolute; font-size: 11px; left: 19px; top: 165px;">

	<div dojoattachpoint="filenameNode">Pict0032z.JPG</div>
	<div style="border: 1px solid rgb(0, 102, 204); padding: 3px 5px; background: white none repeat scroll 0% 0%; -moz-background-clip: -moz-initial; -moz-background-origin: -moz-initial; -moz-background-inline-policy: -moz-initial;">
		<a href="#" dojoattachpoint="viewFullSizeNode" style="text-decoration: none; color: rgb(0, 102, 204); display: none;">View full size</a>
		<span style="display: none;" dojoattachpoint="viewFullSizeNodeSep">&nbsp;|&nbsp;</span>
		<a href="#" dojoattachpoint="saveNode" style="text-decoration: none; color: rgb(0, 102, 204); display: none;">Save to my AOL Pictures</a>
		<span dojoattachpoint="savingNode" style="display: none;">Saving images to my AOL Pictures...</span>

		<span style="display: none;" dojoattachpoint="saveNodeSep">&nbsp;|&nbsp;</span>
		<a href="#" dojoattachpoint="downloadNode" style="text-decoration: none; color: rgb(0, 102, 204);">Download</a>
	</div>
</div></body></html>
From posts in the support forums, this issue is only present whilst using the standard view of AOL mail. Images are shown if you switch to AOL mails basic view.
After reading your comment I see that you are correct, images are displayed in the Basic view.  However, I have not used the Basic view in the past -- I have always used the Standard view and have seen the images displayed.  The ONLY thing I changed was allowing the upgrade from Firefox 3.0.6 to 3.0.7.

If this issue cannot be resolved quickly, please tell me how to move back to Firefox 3.0.6.  I hate using IE as my browser, but I am forced to do that in order to see the attached images.  In fact, some inline images do not display in 3.0.7 either, whereas they did in 3.0.6 and do in IE.  Thanks.
Note: Bugzilla is not for support or help, we want to fix bugs and fixing such bugs needs time.

Old builds are on the ftp server ( ftp://ftp.mozilla.org/ ).
I'm a little bit lost here and i hope that someone else can investigate this issue. The code in question is :

<a href="/41757/aol/en-us/mail/get-attachment.aspx?uid=1.21125773&amp;folder=Inbox&amp;partId=4"
target="_blank"><img style="border: 1px solid rgb(218, 218, 214); visibility:
visible; cursor: pointer; margin-bottom: 30px;" filename="Pict0032z.JPG"
partid="4" class="AOLAttachedImage"
src="/41757/aol/en-us/mail/get-attachment.aspx?uid=1.21125773&amp;folder=Inbox&amp;partId=4">
Thanks very much for your response.  I re-installed 3.0.6 and the attachments now do display correctly, as they did previously in 3.0.6.  So there's got to be some incompatibility issue with 3.0.7.
I will be happy to work with you in solving this issue and testing when necessary.
Thanks for all the info, i will dupe this to bug 482659
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 482659
A better workaround that allows you to have the security of 3.0.7 and still use AOL is to switch to Basic or accessibility mode using the link at the bottom of the page and use 3.0.7.
I would add that this should only be a temorary work-around.  The Basic and Accessability modes are not as user-friendly as the Standard mode.  Of course the goal is to correct the bug and apply it to 3.0.7
This issue is still unresolved as of 3/24/09. Embedded images in AOL webmail do not display.
This is of course unresolved in 3.0.7, how do you expect that a bug gets resolved without updating your Firefox version ?

bug 482659 is marked fixed for the 1.9.0 branch and that means it will be fixed with the coming Firefox 3.0.8
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.