Duplication of United States holiday data.

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
10 years ago
2 years ago

People

(Reporter: stevelauermann, Unassigned)

Tracking

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.18pre) Gecko/20080917 Sunbird/0.9

I dragged and dropped USHolidays.ics into Sunbird.  I then went to File/import and selected the same file.  Both now populate the assigned day on the month gui.  One or the other may be removed manually on a one-by-one basis, but there is no global "undo."  I have tried removing files and entries from the explorer tree and the registry, even removing the application and re-installing--no luck.  At the very least this is user unfriendly...

Reproducible: Always

Steps to Reproduce:
1.drag and drop USHolidays.ics into the Sunbird desktop startup icon.
2.open Sunbird, go to File/Import and import USHolidays.ics
3. 
Actual Results:  
 Look at the calendar--all the holiday entries are duplicates!

Expected Results:  
Logically, I would think one of 2 events should result--
1.  If the application is "burdened with warnings and messages," post warning before second (same/duplicate) .ics file is loaded, "Hey, Bozo--that file is already here--you are going to show 2 entries).  If it is same but newer date, message would be, "Same but newer--you want to install over?  Yes/No"[then, have that process function].
2.  If light on the messages; when same and same date, assume Bozo wants one, don't load second, if newer date, assume new is wanted and load, remove existing.
If older, regardless, don't load.

Regardless of method of loading, results should be as above.
If you import events, then you loose the information from which file they are imported, so its hard to check if these are really the same calendars. Do you maybe have two calendars in the calendar list? Events with the same id shouldn't be on the same calendar twice. Maybe you can just remove one of the two calendars.
(Reporter)

Comment 2

9 years ago
Philipp--

Your comment is barely readable.  

One calendar.
I know same IDs should not show multiple times.

Thanks--

steve

Comment 3

7 years ago
Environment:
Firefox 7.0.1
Thunderbird 7.0.1
Lightning 1.0b7
Provider for Google Calendar 0.8

I'm having the same issue with duplicate events when using the US Holiday calendar.  I got instructions from the Mozilla Thunderbird help site:
https://support.mozillamessaging.com/en-US/kb/Adding-a-holiday-calendar

I already had Lightning installed (this wasn't a new install - it had been installed for a month).  I followed the steps under "Installation" on the Mozilla help site (cut and pasted below).

*****From Here******
    Visit the Mozilla holiday calendar page and right-click the link of the holiday calendar you want to install and select Copy link location.
    Open Thunderbird with Lightning installed.
    Now, switch to calendar view by clicking the Calendar icon next to the tab bar. Next, go to the File menu, select New and select the Calendar... item.
    In the Add a calendar wizard, select On the network and click Next.
    From the Format list, select iCalendar (ICS) and enter the calendar location (with the "file://" prefix) that you just copied into the Address textbox. Click Next.
    Give the holiday calendar a name or leave the default value. If you want, you can select a color in which all of the holidays are highlighted. Click Next
    Click Finish to exit the wizard. 
******To Here********

The US holidays were now displayed in Lightning, but there are two entries for each holiday.
As a measure to reduce the number of issues to a more manageable amount I am closing off this bug because it has been filed before 2010 and is still in the "unconfirmed" state and it has not recently been changed.

If this is still an issue, please test with the latest version of Thunderbird and Lightning and comment on the bug, I am happy to reopen it.

Thank you for your understanding!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.