Closed Bug 481720 Opened 11 years ago Closed 11 years ago

Don't load remote images in mochitests

Categories

(Core :: Disability Access APIs, defect)

defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: surkov, Assigned: MarcoZ)

References

(Blocks 1 open bug)

Details

(4 keywords)

Attachments

(2 files)

No internet connection results 

*** 417 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/a11y/accessible/test_nsIAccessibleHyperLink.html | Wrong startIndex value for ID emptyLink! - got 97, expected 98
*** 418 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/a11y/accessible/test_nsIAccessibleHyperLink.html | Wrong endIndex value for ID emptyLink! - got 98, expected 99
*** 427 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/a11y/accessible/test_nsIAccessibleHyperLink.html | Wrong startIndex value for ID LinkWithSpan! - got 123, expected 124
*** 428 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/a11y/accessible/test_nsIAccessibleHyperLink.html | Wrong endIndex value for ID LinkWithSpan! - got 124, expected 125
*** 442 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/a11y/accessible/test_nsIAccessibleHyperLink.html | Wrong startIndex value for ID namedAnchor! - got 201, expected 202
*** 443 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/a11y/accessible/test_nsIAccessibleHyperLink.html | Wrong endIndex value for ID namedAnchor! - got 202, expected 203
*** 453 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/a11y/accessible/test_nsIAccessibleHyperLink.html | Wrong startIndex value for ID noLink! - got 261, expected 262
*** 454 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/a11y/accessible/test_nsIAccessibleHyperLink.html | Wrong endIndex value for ID noLink! - got 262, expected 263
*** 464 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/a11y/accessible/test_nsIAccessibleHyperLink.html | Wrong startIndex value for ID linkWithClick! - got 300, expected 301
*** 465 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/a11y/accessible/test_nsIAccessibleHyperLink.html | Wrong endIndex value for ID linkWithClick! - got 301, expected 302
*** 474 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/a11y/accessible/test_nsIAccessibleHyperLink.html | Wrong startIndex value for ID linkWithTitleNoNameFromSubtree! - got 353, expected 354
*** 475 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/a11y/accessible/test_nsIAccessibleHyperLink.html | Wrong endIndex value for ID linkWithTitleNoNameFromSubtree! - got 354, expected 355
*** 484 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/a11y/accessible/test_nsIAccessibleHyperLink.html | Wrong startIndex value for ID linkWithTitleNameFromSubtree! - got 402, expected 403
*** 485 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/a11y/accessible/test_nsIAccessibleHyperLink.html | Wrong endIndex value for ID linkWithTitleNameFromSubtree! - got 403, expected 404
*** 494 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/a11y/accessible/test_nsIAccessibleHyperLink.html | Wrong startIndex value for ID linkWithTitleNameFromImg! - got 457, expected 458
*** 495 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/a11y/accessible/test_nsIAccessibleHyperLink.html | Wrong endIndex value for ID linkWithTitleNameFromImg! - got 458, expected 459
*** 504 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/a11y/accessible/test_nsIAccessibleHyperLink.html | Wrong startIndex value for ID linkWithLabelNoNameFromSubtree! - got 461, expected 462
*** 505 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/a11y/accessible/test_nsIAccessibleHyperLink.html | Wrong endIndex value for ID linkWithLabelNoNameFromSubtree! - got 462, expected 463
Duplicate of this bug: 482841
Yeah, this is bad. Tests shouldn't reply on external resources, or they can fail in all kinds of random ways. This test should be fixed or disabled.
Whiteboard: [orange]
I've disabled the two tests that were loading a remote image. Please reenable when the tests have been fixed.

http://hg.mozilla.org/mozilla-central/rev/65ae230e477c
Attached patch PatchSplinter Review
Assignee: nobody → marco.zehe
Status: NEW → ASSIGNED
Attachment #366991 - Flags: review?(surkov.alexander)
Comment on attachment 366991 [details] [diff] [review]
Patch

reassign request to David, I'm not sure I will be able to look soon.

David, it's necessary to check how image maps work here. Because bbc image contains letters, the new one is logically indivisible image iirc. It's possibly worth to create new proper image similar to bbc one.
Attachment #366991 - Flags: review?(surkov.alexander) → review?(david.bolter)
Attached image gif to use
Marco I think we can just use this gif which is based on the bbc one.
Comment on attachment 366991 [details] [diff] [review]
Patch

Alexander approves of the image I attached, so if you can use that instead, r=me.
Pushed in changeset:
http://hg.mozilla.org/mozilla-central/rev/86c22329f87b
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Attachment #366991 - Flags: approval1.9.1+
Pushed to m-1.9.1 in changeset:
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/57cab9f9262d
Keywords: access, fixed1.9.1
Checked into CVS trunk:
Checking in accessible/tests/mochitest/Makefile.in;
/cvsroot/mozilla/accessible/tests/mochitest/Makefile.in,v  <--  Makefile.in
new revision: 1.27; previous revision: 1.26
done
RCS file: /cvsroot/mozilla/accessible/tests/mochitest/letters.gif,v
done
Checking in accessible/tests/mochitest/letters.gif;
/cvsroot/mozilla/accessible/tests/mochitest/letters.gif,v  <--  letters.gif
initial revision: 1.1
done
Checking in accessible/tests/mochitest/test_nsIAccessibleHyperLink.html;
/cvsroot/mozilla/accessible/tests/mochitest/test_nsIAccessibleHyperLink.html,v  <--  test_nsIAccessibleHyperLink.html
new revision: 1.4; previous revision: 1.3
done
Checking in accessible/tests/mochitest/test_nsIAccessibleHyperText.html;
/cvsroot/mozilla/accessible/tests/mochitest/test_nsIAccessibleHyperText.html,v  <--  test_nsIAccessibleHyperText.html
new revision: 1.2; previous revision: 1.1
done
Keywords: fixed1.9.0.12
Blocks: 438871
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.