Sending URLs to Firefox still doesn't work if Firefox is already running

RESOLVED INVALID

Status

()

Toolkit
Startup and Profile System
RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: Jesse Ruderman, Unassigned)

Tracking

1.9.1 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
The fix from bug 380163 doesn't seem to be working for me (or I'm
misunderstanding what it was fixing).  I still get "Close Firefox: A
copy of Firefox is already open. Only one copy of Firefox can be open
at a time." when I do things like:

Macintosh:~ jruderman$
~/central/opt-obj/dist/Minefield.app/Contents/MacOS/firefox
http://www.squarefree.com/
Macintosh:~ jruderman$
~/central/opt-obj/dist/Minefield.app/Contents/MacOS/firefox -url
http://www.squarefree.com/
Macintosh:~ jruderman$
~/central/opt-obj/dist/Minefield.app/Contents/MacOS/firefox-bin -url
http://www.squarefree.com/

The same Minefield is the one that's already running.
I don't think this is valid.  If you want to get a url to the running app, you need to use an Apple Event, so use:

$ open <url>

Trying to do this by running the binary inside the bundle again isn't going to work.  This is what my research shows, but someone please correct me if I'm wrong.

Comment 2

9 years ago
Using Mac and 3.1 beta 2 I'm having a similar issue.  When I use the "open" command from the command line, firefox properly opens a new window.  When I click links inside certain other applications, they try to launch firefox and firefox reports that an instance is already running.  Although this sounds like its the calling application that is to blame, this behavior did not happen in firefox 3.0 and this is a problem with multiple applications.  For example, Adobe Drive CS4 has a "Settings" button that launches the default web browser.  If Safari is the default web browser or Firefox 3.0, there are no problems.  If 3.1b2 is the default, I don't even get to see what URL was being loaded, I just get a failure.  

On a related note, if I quit FF and try it then, it sometimes works and sometimes doesn't...

I think this is the right bug for this, but perhaps there is another or it should be a new bug?
(In reply to comment #2)
> I think this is the right bug for this, but perhaps there is another or it
> should be a new bug?

Also note bug 480733.

Comment 4

9 years ago
This bug as filed is INVALID. You can't run the firefox binary twice on Mac.

Patrick Walsh, whatever you see is a different bug. If you can come up with steps to reproduce, please file it separately (and cc me).
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID

Comment 5

9 years ago
David, the issue I'm having seems pretty different from bug 480733, but thank you.

Benjamin, thank you, let me see if I can come up with a good way to reproduce this (that doesn't require Adobe Drive CS4 or other paid programs) and I will file it as a new issue.
(Reporter)

Comment 6

9 years ago
The "open -a minefield url" workaround certainly works.  But what am I misunderstanding about bug 380163?

Comment 7

9 years ago
I'm not using nightly builds so the fix for bug 380163 may have fixed it.  I didn't find that one in my search.  I'll sit tight and see what happens with the next beta.  Just for some extra info though, Adobe CS4 suite of tools causes this to happen reliably when trying to use the help feature or really any link from within the program.  On another machine with FF3.0, it works...  I'll go silent now and refile as a new bug if the problem remains in the next beta.
You need to log in before you can comment on or make changes to this bug.