Typing any character on the keyboard causes multiple instances of 'The 'charCode' property of a keyup event should not be used. The value is meaningless.' to appear in the Error Console.

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
10 years ago
9 years ago

People

(Reporter: geeknik, Unassigned)

Tracking

3.5 Branch
x86
Windows Vista
Points:
---
Bug Flags:
blocking-firefox3.6 -
wanted-firefox3.6 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b4pre) Gecko/20090305 Shiretoko/3.1b4pre (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b4pre) Gecko/20090305 Shiretoko/3.1b4pre (.NET CLR 3.5.30729)

I'm using Firefox 3.1b4pre and I've noticed this in past 3.1b3pre builds as well.  The Error Console has literally dozens and dozens of instances of the following:

Warning: The 'charCode' property of a keyup event should not be used. The value is meaningless.
Source File: chrome://browser/content/browser.xul
Line: 0

It doesn't matter where I go or what I'm doing, this error comes up. Granted, it's just a warning, but it's filling up the Error Console with useless and meaningless information. Line 0 doesn't even exist.

Reproducible: Always

Steps to Reproduce:
1. Launch Firefox 3.1b4pre
2. Visit any web site.
3. Tools -> Error Console
Actual Results:  
Look for the mass instances of "The 'charCode' property of a keyup event should not be used. The value is meaningless."

Expected Results:  
The warning should not exist. There is no line 0 in chrome://browser/content/browser.xul
(Reporter)

Comment 1

10 years ago
Created attachment 365749 [details]
screencap of error console in latest Firefox 3.1b4pre build.
(Reporter)

Comment 2

10 years ago
While typing a comment in this box, I can sit and watch the error console on the opposite monitor filling up with this error message. Every time I hit a key on the keyboard, this message appears and it doesn't matter what key I hit on the keyboard.
(Reporter)

Updated

10 years ago
Severity: normal → minor
Summary: Error console contains multiple instances of 'The 'charCode' property of a keyup event should not be used. The value is meaningless.' → Typing any character on the keyboard causes multiple instances of 'The 'charCode' property of a keyup event should not be used. The value is meaningless.' to appear in the Error Console.
Version: unspecified → 3.1 Branch
(Reporter)

Comment 3

10 years ago
Still present in the 200905020041838 build of Shiretoko.
(Reporter)

Comment 4

9 years ago
This is still present in the 20090820045318 build of Minefield 3.7a1pre. Every keystroke causes the following to appear over and over and over. :)

Warning: The 'charCode' property of a keyup event should not be used. The value is meaningless.
Source File: chrome://browser/content/browser.xul
Line: 0

Any chance this is going to be fixed soon? Or any way to get the browser to ignore this so it doesn't flood my error console with crap?

Comment 5

9 years ago
This is seriously impacting performance of typing characters in any textbox, as each key press generates an error message in the console.
Severity: minor → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: wanted-firefox3.6?
Flags: blocking-firefox3.6?
I can't reproduce this on OSX or Windows using the STR in comment 0. Resolving WFM, and I'm pretty sure that if it were widespread, we'd have seen tonnes of dupes.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Flags: wanted-firefox3.6?
Flags: wanted-firefox3.6-
Flags: blocking-firefox3.6?
Flags: blocking-firefox3.6-
Resolution: --- → WORKSFORME
Looks like you've got a theme installed, there. Have you guys tried this on a clean profile?

Feel free to reopen if you get new data!
You need to log in before you can comment on or make changes to this bug.