sort by group works wrong when you use quick search

RESOLVED WORKSFORME

Status

Thunderbird
Mail Window Front End
RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: liuchongjin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS i86pc; en-US; rv:1.9.1b2) Gecko/20090126 Firefox/3.1b2
Build Identifier: Mozilla/5.0 (X11; U; SunOS i86pc; en-US; rv:1.9.1b3pre) Gecko/20090224 Lightning/1.0pre Thunderbird/3.0b1

when you use quick search to list the special messages in your inbox, using the sort by group function, not only the messages which are searched out are sorted by group but all the messages in inbox are there.

Reproducible: Always

Steps to Reproduce:
1.In the inbox, enter something in you quick search box (for example 'mozilla')
2.Go to View | Sort by and select Grouped by Sort

Actual Results:  
all the messages in you inbox will be sorted by group

Expected Results:  
only the messages which you have searched should be sorted by group

Comment 1

9 years ago
likely duplicate
Component: Toolbars and Tabs → Mail Window Front End
QA Contact: toolbars-tabs → front-end

Comment 2

9 years ago
problem reproduced using this build on OpenSolaris 5.11 i86pc

thunderbird-3.0b3pre.en-US.solaris2.11-i386.tar.bz2    29-Mar-2009 12:38     17M
from http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/contrib/latest-trunk/

version 3.0b3pre
Mozilla/5.0 (X11; U; SunOS i86pc; en-US; rv:1.9.1b4pre) Gecko/20090329
Shredder/3.0b3pre

Updated

9 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

9 years ago
This seems to be fixed in TB 3RC1
WFM per comment #3
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.