1754 wikipages don't have an associated language in tiki_translated_objects

RESOLVED INVALID

Status

support.mozilla.org
Knowledge Base Software
RESOLVED INVALID
9 years ago
7 years ago

People

(Reporter: Cww, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
Created attachment 365832 [details]
wiki pages with missing entries in tiki_translated_objects

As far as I can tell tiki_translated_objects is the table that stores what language a given wikipage is in.  However, doing queries, I find that there are 1754 wikipage objects (not including staging articles) in tiki_objects that don't have an associated row in tiki_translated_objects and thus can't be queried for their language.  I thought we fixed this at some point in the past but it looks like we haven't.  (This set represents about 50% of all tiki_objects and 75% of all actively edited wiki pages so it must still be possible to make articles without languages).  Most of them are not English articles.

I've attached a list generated by this query:
SELECT tob.name FROM tiki_objects tob WHERE objectId NOT IN (SELECT objId FROM tiki_translated_objects tto) AND tob.type = 'wiki page' AND tob.name REGEXP '^[^[.*.]]' ORDER BY tob.name;
I guess we should create a separate page and ask for user's help to assign languages to these. Is there a way to do that? Also on this page, we should alert users to log bugs when they find a way to reproduce a page getting on there (having no language).

I think removing the "Unknown" and/or defaulting to English on tiki-editpage.php will solve the issue for all English language articles.
Bugs in tikiwiki, going away.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.