No loading of CalDav Calendar due to errors regarding parsing eTags

RESOLVED FIXED in 1.0b1

Status

defect
RESOLVED FIXED
11 years ago
10 years ago

People

(Reporter: simon.taiko, Assigned: Fallen)

Tracking

unspecified
1.0b1

Details

Attachments

(1 attachment)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2) Gecko/20081201 Firefox/3.1b2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070802 SeaMonkey/1.1.4 Mnenhy/0.7.4.0

I have a problem loading the calendar from a CalDav provider, when thunderbird is started, the calendar is not loaded nor is it loaded anytime. I can create events which then show up in the calendar, both in lightning and online , but disappear from lightning when I restart thunderbird.
I'm using Thunderbird 3 beta 2 and the newest nightly build lightning (03-05-09), the calendar is password protected (https) in combination with a SSL email adress and thunderbird asks for my password upon start-up.

Following error code in error console:

CalDAV: Status 207 on initial PROPFIND for calendar "calendarname"
CalDAV: Authentication scheme Basic
CalDAV: Bad response to in/outbox query, status 500
Error: r.getcontenttype is undefined
Source File: file:///D:/Profiles/Thunderbird/uzq63fi2.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///D:/Profiles/Thunderbird/uzq63fi2.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calDavRequestHandlers.js
Line: 288
CalDAV: Fatal Error parsing etags for Advanced MEA
Error: [Exception... "Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsISAXXMLReader.onDataAvailable]"  nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame :: file:///D:/Profiles/Thunderbird/uzq63fi2.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///D:/Profiles/Thunderbird/uzq63fi2.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calDavRequestHandlers.js :: eSL_onDataAvailable :: line 221"  data: no]
Source File: file:///D:/Profiles/Thunderbird/uzq63fi2.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///D:/Profiles/Thunderbird/uzq63fi2.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calDavRequestHandlers.js
Line: 221

Reproducible: Always

Steps to Reproduce:
1.Enter calendar specifics
2.Restart Thunderbird
3.No calendar is shown
Actual Results:  
Same as above

Expected Results:  
Load the calendar

default theme used, add-ons: lightning, lightning nightly updater, quick locale switcher, nightly tester tools, WΓΆrterbuch \"Deutsch(Schweiz)\"
Could you obtain (somehow, i.e wireshark if you are not using ssl) the XML that your server is responding with? I assume that the server is not sending the <getcontenttype>, even though we are requesting it.

What server are you using?
Summary: No loading of CalDev Calendar probably due to errors regarding parsing eTags → No loading of CalDav Calendar due to errors regarding parsing eTags
Hmm, I do use SSL, so I don't know. Additionally its the server from our university and there is no information whatsoever on the web regarding the communication form.

However, the calendar work fine with Thunderbird 2.0.x and Lightning 0.9, which is the reason I thought that it's a bug within lightning.
I agree lightning can be a bit more graceful on this matter, then we would also see what XML the server is sending. Maybe you can use some tunneling to find the XML before I be more graceful here (i.e stunnel).

Does your university have some sort of guest account I can access?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Maybe setting both "calendar.debug.log" and "calendar.debug.log.verbose" to "true" could provide more information about the data in the console?
Following additional information came when calendar.debug.log.verbose was set to true:

Warning: There has been an error reading data for calendar: "calendar".  However, this error is believed to be minor, so the program will attempt to continue. Error code: DAV_NOT_DAV. Description: The resource at "calendar" is either not a DAV collection or not available

Warning: There has been an error reading data for calendar: "calendar".  However, this error is believed to be minor, so the program will attempt to continue. Error code: READ_FAILED. Description:


Unfortunately though, our university has no guest accouts and regarding the tunneling I have to admit that I don't know how to use stunnel, if you could give me some instructions (I have downloaded the precompiled version for windows).
Posted patch Fix - v1 β€” β€” Splinter Review
This fixes the problem with Simon's server and also makes caldav a bit more fault tolerant when parsing the calendar data fails. This is a good start for the activity manager stuff in bug 455260.
Assignee: nobody → philipp
Status: NEW → ASSIGNED
Attachment #368259 - Flags: review?(dbo.moz)
BTW: The problem is that your server doesn't respond to <getcontenttype> at all. The element is not present in the response from the server. Not 100% sure if this is strictly required, but I think all caldav servers need to respond to <getcontenttype> with the correct mime type. They at least need to response that this is not supported (i.e. the prop itself has status 404)
Thanks! What do I have to do next? Do I have to integrate the fix myself or can I just wait and download the next nightly?
If you'd like to test, go ahead and apply the patch yourself. Otherwise you can wait until Daniel has reviewed this and I have checked it in. It should be in the next nightly build after check in.
Attachment #368259 - Flags: review?(dbo.moz) → review+
Comment on attachment 368259 [details] [diff] [review]
Fix - v1

looks good; r=dbo
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/2ebb18326ffb>

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
OS: Windows XP → All
Hardware: x86 → All
Resolution: --- → FIXED
Target Milestone: --- → 1.0
Duplicate of this bug: 457206
Target Milestone: 1.0 → 1.0b1
You need to log in before you can comment on or make changes to this bug.