Last Comment Bug 481860 - Get rid of RTL search icons by using mirror transformations
: Get rid of RTL search icons by using mirror transformations
Status: VERIFIED FIXED
: rtl
Product: Toolkit
Classification: Components
Component: Themes (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla1.9.2a1
Assigned To: :Ehsan Akhgari (out sick)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-06 06:06 PST by Markus Stange [:mstange]
Modified: 2013-04-18 19:49 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (v1) (1.43 KB, patch)
2009-03-08 08:13 PDT, :Ehsan Akhgari (out sick)
no flags Details | Diff | Review
Patch (v2) (15.98 KB, patch)
2009-03-08 10:02 PDT, :Ehsan Akhgari (out sick)
asaf: review+
Details | Diff | Review

Description Markus Stange [:mstange] 2009-03-06 06:06:23 PST
This idea came up in bug 462977 comment 6 and I'd like to try it out.
Comment 1 :Ehsan Akhgari (out sick) 2009-03-08 08:13:09 PDT
Created attachment 366185 [details] [diff] [review]
Patch (v1)

The Mac theme didn't originally flip the search button, so I didn't touch it.  Is there a specific reason for this behavior, though?
Comment 2 :Ehsan Akhgari (out sick) 2009-03-08 08:14:49 PDT
Markus: I'm not sure if this bug has been filed about the search bar or everywhere this image is used, so I'm assuming the former.  Please correct me if I'm wrong.
Comment 3 Dão Gottwald [:dao] 2009-03-08 08:32:17 PDT
Is there a reason not to do this for all occurrences of Search-glass-rtl.png?
Comment 4 Dão Gottwald [:dao] 2009-03-08 08:53:27 PDT
We should also remove Search-glass.png from browser/themes/ and use the toolkit image everywhere.
Comment 5 Dão Gottwald [:dao] 2009-03-08 09:03:46 PDT
Morphing... I know Markus had more in mind than the search glass, but I think bug 482105 will be more useful with regard to the RTL layout of the search bar on OS X.
Comment 6 :Ehsan Akhgari (out sick) 2009-03-08 09:33:35 PDT
(In reply to comment #4)
> We should also remove Search-glass.png from browser/themes/ and use the toolkit
> image everywhere.

What was the original reason that that icon went into browser/themes/?  Would removing it fall into the scope of this bug?
Comment 7 Dão Gottwald [:dao] 2009-03-08 09:38:49 PDT
It was needed in browser but not in toolkit, so it was in browser first. When toolkit needed it, it has been copied, since toolkit can't depend on browser.
Comment 8 Dão Gottwald [:dao] 2009-03-08 09:43:50 PDT
(In reply to comment #6)
> Would removing it fall into the scope of this bug?

You need to touch the surrounding code anyway, and it's trivial, so I'd say it's not out of scope. But feel free not to do it here.
Comment 9 :Ehsan Akhgari (out sick) 2009-03-08 10:02:42 PDT
Created attachment 366195 [details] [diff] [review]
Patch (v2)

Remove browser versions of the search-glass icon, and also toolkit RTL versions, and use -moz-transform to flip the icon for RTL.
Comment 10 Mano (::mano, needinfo? for any questions; not reading general bugmail) 2009-04-02 00:25:08 PDT
Comment on attachment 366195 [details] [diff] [review]
Patch (v2)

r=mano
Comment 11 :Ehsan Akhgari (out sick) 2009-04-03 02:34:35 PDT
http://hg.mozilla.org/mozilla-central/rev/8277119139f6

We need a Litmus test to verify that the icons have been properly flipped.
Comment 12 Henrik Skupin (:whimboo) 2009-04-06 05:03:39 PDT
Verified fixed with Mozilla/5.0 (Windows; U; Windows NT 5.1; fa; rv:1.9.2a1pre) Gecko/20090405 Minefield/3.6a1pre ID:20090405044922

Markus, do we already have a bug for OS X?
Comment 13 :Ehsan Akhgari (out sick) 2009-04-06 05:16:01 PDT
(In reply to comment #12)
> Markus, do we already have a bug for OS X?

Bug 482105; see comment 5.

Note You need to log in before you can comment on or make changes to this bug.