Strange bug in l10n dashboard reports (reporting not existing problems)

RESOLVED FIXED

Status

Mozilla Localizations
Infrastructure
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: stef, Assigned: Pike)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; pl; rv:1.9.1b2) Gecko/20081201 Firefox/3.1b2
Build Identifier: 

http://l10n.mozilla.org/buildbot/compare/hg-comm-langpack/16512 is reporting
missing notifyRightsText in pl/mail/chrome/messenger/aboutRights.properties with obsolete notifyText.

The problem is that it was changed some time ago: http://hg.mozilla.org/releases/l10n-mozilla-1.9.1/pl/rev/6d740695f20d



Reproducible: Always
(Assignee)

Comment 1

9 years ago
The problem here is that I pull -r tip, which pulls the relbranch and not the latest changes on default, if the relbranch head is newer.

I'm using hg 1.1.2 on the l10n server now, so specifying a revision for pull is not longer required to work around the 1.0 race, so I'll remove that part.

Coop, Armen, do you know which hg versions we use on the releng machines?
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Comment 2

9 years ago
Created attachment 366025 [details] [diff] [review]
use the fixed factory instead of the old one

This is somewhat of an explicit fix, I'm converting the comm-central builds over to my new build factory stuff, which takes care of this bug.
Assignee: nobody → l10n
(Assignee)

Comment 3

9 years ago
http://hg.mozilla.org/users/axel_mozilla.com/tooling/rev/a31e2fc2dc70, FIXED.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.