Intermittent (imgCacheEntry or imgRequest) leak in browser tests

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
11 years ago
7 years ago

People

(Reporter: joe, Unassigned)

Tracking

({intermittent-failure, memory-leak})

Trunk
x86
Windows Server 2003
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

WINNT 5.2 mozilla-central unit test box leaked an imgCacheEntry or imgRequest during the browser tests. (The bug URL is the test output.) This might be an intermittent thing, or it might be something that's being newly tickled by some code changes. We won't know which until some more unit test runs cycle.
I'm also updating my Vista VM's build so I can run the unittests over and over again in an attempt to reproduce the leak.
Box just cycled green, so it's definitely an intermittent thing.
Summary: Intermittent (?) leak in browser tests → Intermittent leak in browser tests
Whiteboard: [orange]
Blocks: 438871
OS: Mac OS X → Windows Server 2003
R.WFM, after no new report since almost 7 months.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → WORKSFORME
Summary: Intermittent leak in browser tests → Intermittent (imgCacheEntry or imgRequest) leak in browser tests
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.