If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Wrong font size when rendering style sheet text

VERIFIED INVALID

Status

()

Core
CSS Parsing and Computation
P3
normal
VERIFIED INVALID
17 years ago
9 years ago

People

(Reporter: jbrady, Assigned: Pierre Saslawsky)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
In all my site a style sheet for tables is used, which defines a font-size of 10pt.
Mozilla M17 uses size 14 instead. So instead of decreasing the size, it
increases it.

Comment 1

17 years ago
Does this test case illustrate your problem?

Comment 2

17 years ago
Created attachment 12595 [details]
Tables resist styling, as illustrated here.

Comment 3

17 years ago
Note that IE behaves similarly, but not identically:  it displays Table 2 as the
reporter and I would expect, but treats Table 3 the same way Mozilla Build ID
2000080808 does.

Comment 4

17 years ago
Can't shut me up:  should add that I'm seeing this on NT.

Updated

17 years ago
Assignee: asa → pierre
Status: UNCONFIRMED → NEW
Component: Browser-General → Style System
Ever confirmed: true
QA Contact: doronr → chrisd

Comment 5

17 years ago
confirmed 080908 mozilla build on MacOS9

Comment 6

17 years ago
Created attachment 12730 [details]
Correct behavior using STRICT dtd

Comment 7

17 years ago
Using: Build 2000-08-09-08 on Windows 98
I modified the first attachment to be HTML 4.01 STRICT compliant, and it appears
to render correctly.  But NOT if I specify doctype transitional.
This is related to the tables-don't-inherit-stuff bug, recommend WONTFIX or
Future since we have a lot more important bugs on our plate.

Comment 9

17 years ago
This is correct NavQuirks behavior. Marking INVALID. Please see bug 1044 fo some 
of the history on this one (there is a lot).
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 10

17 years ago
Adding 'verifyme' keyword
Keywords: verifyme

Comment 11

17 years ago
Verified invalid.
Status: RESOLVED → VERIFIED

Comment 12

13 years ago
http://www.justdave.net/dave/article.php?story=20050107003727277 -> Fixing
OS: All
Hardware: Macintosh → All

Updated

9 years ago
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.