If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Crash [@ nsGlobalWindow::ResumeTimeouts]

VERIFIED FIXED in mozilla1.9.2a1

Status

()

Core
DOM
P1
critical
VERIFIED FIXED
9 years ago
4 years ago

People

(Reporter: Jesse Ruderman, Assigned: smaug)

Tracking

({crash, verified1.9.1})

Trunk
mozilla1.9.2a1
crash, verified1.9.1
Points:
---
Bug Flags:
blocking1.9.1 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [sg:critical?], crash signature, URL)

Attachments

(2 attachments)

2.37 KB, text/plain
Details
982 bytes, patch
Ben Turner (not reading bugmail, use the needinfo flag!)
: review+
Details | Diff | Splinter Review
(Reporter)

Description

9 years ago
Created attachment 366021 [details]
stack trace

Loading http://www.beyondspaceandtime.org/FCBSTWeb/web/index.html triggers a scary crash in nsGlobalWindow::ResumeTimeouts.
Flags: blocking1.9.2?
This crashes B3 candidate as well using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3) Gecko/20090305 Firefox/3.1b3.
(Reporter)

Comment 2

9 years ago
Hmm, I hit this the first three times I loaded the URL, but now I'm having trouble reproducing.  But Marcia's comment convinces me that I'm not crazy :)
Same on Windows XP: bp-2d8e9e84-8f5a-4245-8e45-904ae2090306

0  	xul.dll  	nsGlobalWindow::ResumeTimeouts  	dom/src/base/nsGlobalWindow.cpp:8518
1 	xul.dll 	nsResumeTimeoutsEvent::Run 	content/base/src/nsXMLHttpRequest.cpp:155
2 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:510
3 	xul.dll 	nsBaseAppShell::Run 	widget/src/xpwidgets/nsBaseAppShell.cpp:170
4 	nspr4.dll 	PR_GetEnv 	
5 	firefox.exe 	wmain 	toolkit/xre/nsWindowsWMain.cpp:87
6 	firefox.exe 	firefox.exe@0x2197 	
7 	kernel32.dll 	BaseProcessStart 	

I'ld tend to dupe it against one of the other nsGlobalWindow::ResumeTimeouts crashes we already have. It really looks like the same as bug 480970.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Flags: blocking1.9.2?
Keywords: testcase-wanted
OS: Mac OS X → All
Hardware: x86 → All
Resolution: --- → DUPLICATE
Duplicate of bug: 480970
(Assignee)

Updated

9 years ago
Component: Event Handling → DOM
QA Contact: events → general
(Assignee)

Comment 4

9 years ago
Created attachment 366113 [details] [diff] [review]
patch

This fixes the crash for me.
Assignee: nobody → Olli.Pettay
Status: RESOLVED → REOPENED
Attachment #366113 - Flags: superreview?(jst)
Attachment #366113 - Flags: review?(bent.mozilla)
Resolution: DUPLICATE → ---
(Assignee)

Comment 5

9 years ago
I uploaded the patch to tryserver.
The build will appear here https://build.mozilla.org/tryserver-builds/?C=M;O=D
tca and opettay in its name.
(Assignee)

Updated

9 years ago
Flags: blocking1.9.1?
(Assignee)

Comment 6

9 years ago
Martijn, any chance this fixes bug 480970 too?
Attachment #366113 - Flags: review?(bent.mozilla) → review+
Comment on attachment 366113 [details] [diff] [review]
patch

Oh this is nasty. Wonder how long this bug has been lurking...

Updated

9 years ago
Duplicate of this bug: 480970
(Reporter)

Updated

9 years ago
Blocks: 340345

Updated

9 years ago
Attachment #366113 - Flags: superreview?(jst) → superreview+
Comment on attachment 366113 [details] [diff] [review]
patch

Oh, fun. Good find! sr=jst
I think we should take this crash fix for 1.9.1 b3, assuming there's time. I've sent off an email asking what can be done here as far as getting this in for b3.
Flags: blocking1.9.1? → blocking1.9.1+
Priority: -- → P1
Target Milestone: --- → mozilla1.9.1b3
(Assignee)

Comment 11

9 years ago
http://hg.mozilla.org/mozilla-central/rev/dbfc5db244d0
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → FIXED
(Assignee)

Comment 12

9 years ago
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/844e56e8f421
Keywords: fixed1.9.1
Verified fixed on trunk and 1.9.1 with builds on OS X and Windows:

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20090310 Minefield/3.2a1pre

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b4pre) Gecko/20090309 Shiretoko/3.1b4pre
Status: RESOLVED → VERIFIED
Keywords: fixed1.9.1 → verified1.9.1
Target Milestone: mozilla1.9.1b3 → mozilla1.9.2a1
(Reporter)

Updated

9 years ago
Whiteboard: [sg:critical?]
Crash Signature: [@ nsGlobalWindow::ResumeTimeouts]
Group: core-security
You need to log in before you can comment on or make changes to this bug.