Threadsafe assertion when the "What's Related" tab is clicked.

VERIFIED FIXED

Status

()

P3
normal
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: laquinta, Assigned: laquinta)

Tracking

Trunk
x86
OS/2
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

18 years ago
A threadsafe assertion occurs when the "What's Related" Tab is clicked.
It looks to be an xpcom threading priority issue.  On OS/2 the trap 
seems to be due to a mishandling of the assertion itself.  The 
assertion very likely occurs on other platforms, but does not crash the 
entire brower.

Comment 1

18 years ago
setting bug status to New
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

18 years ago
Created attachment 13746 [details] [diff] [review]
Fix for OS/2 specific code in nsDebug.cpp to not Break on error

Comment 3

18 years ago
Checked in fix
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 4

18 years ago
Verified in debug build
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.