Closed Bug 482159 Opened 12 years ago Closed 12 years ago

Body area restricted to content and does not cover at least the whole viewport

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 147436

People

(Reporter: cacyclewp, Unassigned)

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.7) Gecko/2009021910 Firefox/3.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.7) Gecko/2009021910 Firefox/3.0.7

In Firefox the body area does not cover at least the whole viewport as in all other tested browsers (MS IE and WebKit/Safari/Chrome). Instead, the body area covers only the body's content, leaving large parts of the viewport/screen as a "nowhere land" that does not belong to any stylable element and for which certain style properties cannot be changed. 

The area affected by body.style differs between style properties:
body.style.backgroundColor="red" colors the whole vieport as it should, but
body.style.cursor="move" restricts the changed cursor to the much smaller content area and it is impossible to change the cursor appearance outside the body content area.

(The latter is important for changing the cursor while resizing the edit frame of the Wikipedia rich text editor wikEd http://en.wikipedia.org/wiki/User:Cacycle/wikEd)

As in all other browsers, the area of the body element should fill at least the whole viewport.
 


Reproducible: Always
The root element of xhtml is the <html> element the <body> is not the entire document.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 147436
This testcase shows a small body (also containing an iframe in designmode) with border, background, and cursor styling. style backgroundColor applies to whole viewport while cursor styling is restricted to much smaller area indicated by the border. In all other browsers the bordered area extends to at least the whole viewport and the cursor style applies to the whole visible area or iframe.
So how can I style the "nowhere land" outside the body area. Setting the style on the HTML element has the same effect doing it on the BODY element.
Similar testcase with styles applied to HTML instead of BODY elements - there is no difference.
Just for future reference:

The empty space around the body area does not belong to any DOM element and no styles can be applied.

But it is possible to maximize the body area to the full screen size by setting the height of either BODY or of HTML to 100%. To achieve the same in an IFRAME only setting the IFRAME's BODY to 100% works.
You need to log in before you can comment on or make changes to this bug.