Closed Bug 482277 Opened 11 years ago Closed 11 years ago

stop using FlatCarbon headers on Mac OS X

Categories

(Firefox Build System :: General, defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
mozilla1.9.2a1

People

(Reporter: jaas, Assigned: jaas)

References

Details

Attachments

(2 files, 1 obsolete file)

We should stop using FlatCarbon headers on Mac OS X. We should be using the preferred method of including umbrella headers for the Carbon framework.
Attached patch fix v1.0 (obsolete) — Splinter Review
The only interesting changes here are in:

- configure.in
- media/liboggplay/src/liboggplay/Makefile.in

The rest just substitutes Carbon and CoreFoundation framework includes for individual headers. The liboggplay code depends on FlatCarbon, that should be changed upstream.
Attachment #366331 - Flags: review?(benjamin)
updated to current trunk
Attachment #366331 - Attachment is obsolete: true
Attachment #367654 - Flags: review?(benjamin)
Attachment #366331 - Flags: review?(benjamin)
Attachment #367654 - Flags: review?(benjamin) → review+
pushed to mozilla-central

http://hg.mozilla.org/mozilla-central/rev/b8dde9bd2738
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
This broke my mozilla-central xulrunner build:

In file included from /Users/gavin/mobile/mozilla/xulrunner/stub/nsXULStub.cpp:56:
../../dist/include/system_wrappers/CFBundle.h:3:27: error: CFBundle.h: No such file or directory

Should that just be including <CoreFoundation/CoreFoundation.h> instead?
Yup, I missed that one. Pushed a fix to mozilla-central:

http://hg.mozilla.org/mozilla-central/rev/35c8ac2aac22
Out of curiosity, how did this -not- turn tinderboxes red?
Because we don't have any mac XULRunner tinderboxes on mozilla-central.
Duplicate of this bug: 194575
Fwiw, I notice that
*/config/system-headers
*/js/src/config/system-headers
*and some other code files
still include the individual headers: is that expected?
Flags: in-testsuite-
Target Milestone: --- → mozilla1.9.2a1
That's what mxr searches found.
Attachment #427014 - Flags: superreview?(bugzilla)
Attachment #427014 - Flags: review?(bugzilla)
Nothing needs to be including individual Carbon headers.
(In reply to comment #11)
> Nothing needs to be including individual Carbon headers.

I filed bug 546458.
Attachment #427014 - Flags: superreview?(bugzilla)
Attachment #427014 - Flags: superreview+
Attachment #427014 - Flags: review?(bugzilla)
Attachment #427014 - Flags: review+
Attachment #367654 - Attachment description: fix v1.1 → fix v1.1 [Checkin: See comment 3+5]
Comment on attachment 427014 [details] [diff] [review]
(Cv1-CC) Port this to comm-central too
[Checkin: Comment 13]


http://hg.mozilla.org/comm-central/rev/867fb51b75d8
Attachment #427014 - Attachment description: (Cv1-CC) Port this to comm-central too → (Cv1-CC) Port this to comm-central too [Checkin: Comment 13]
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.