Missing Application Icon in the system task menu

RESOLVED DUPLICATE of bug 487174

Status

Fennec Graveyard
General
RESOLVED DUPLICATE of bug 487174
9 years ago
9 years ago

People

(Reporter: dougt, Unassigned)

Tracking

Trunk
x86
Windows Mobile 6 Professional

Details

(Reporter)

Description

9 years ago
In windows Mobile 6.1, there is a drop down menu on the right hand side of the Today Screen.  When pressed, a list of all running applications are display along with their icon.  For some reason, the icon for Fennec is not displayed in this list.
(Reporter)

Comment 1

9 years ago
I thought that this might be related to 476954.  However, it looks like the Task Manager just looks for a icon resource in the exe, and does not look at the window icon (set via WM_SETICON).
Depends on: 487174
No longer depends on: 487174
I'm wondering if bug 482741 is the root cause of this problem.
As far as I test on emulator, WM_SETICON does not affect the icon in task manager.

As Doug said in comment #1, WinCE seems to use the resource icon which has the smallest resource ID number in all resource icons.
Hiroyuki - Agreed. In fact, since the xulrunner-stub fix landed, I haven't seen Fennec show up in the task manager without it's icon. Now the only problem seems to be that Fennec doesn't always show up in the task manager - but when it does, the icon is there.
Since bug 482741 covers the "not always showing up in the task manager", can we close this bug out?
I agree. We should close this bug.
I am closing this bug.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 487174
You need to log in before you can comment on or make changes to this bug.