Firefox does not present me with a "Save target as...." option when attempting to download mp3 files from this subscription service.

RESOLVED WONTFIX

Status

()

Firefox
File Handling
--
enhancement
RESOLVED WONTFIX
9 years ago
7 years ago

People

(Reporter: bentnhaf, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5
Build Identifier: Firefox/3.0.7

I subscribe to the "Coast to Coast AM" radio show web site streamlink service which allows me to download recorded previous broadcasts.

They have a link to a 'trouble shooting' page to assist those who are having difficulty downloading the mp3 files or stream links they(me) are entitled to as a result of my subscription....

http://www.coasttocoastam.com/gen/page403.html?theme=light

...and one of the suggestions is to right click on the mp3 file listed that I want to download and choose the "Save target as..." option.

ie allows me to do this, firefox does not.  firefox is my browser of choice but every time I want to download a show, I have to use ie for this task.

Reproducible: Always

Steps to Reproduce:
1.auto login to my account.
2.go to the archive page and choose the specific show that I'm interested in.
3.choose the 1st of 4 mp3 file downloads that is one fourth of the recorded broadcast by right clicking on it and choosing, "Save target as..."

Actual Results:  
4.the closest thing that firefox has to that is "Save link as..." and when you do, it presents an html file to save whereas ie presents an mp3 file to save.

Expected Results:  
its supposed to present me with an mp3 file to save.

this 'problem' may not technically be a "bug"....but anything that forces me to use ie bugz the hell out of me!
Save Link As saves whatever the site is returning when you click the link.  If you're getting an HTML file, that's what the link is returning.  If you left click, do you get a new page?
(Reporter)

Comment 2

9 years ago
If you had reproduced this behavior as I detailed above as an account holder, you would not have asked this question.

As I said above, "Save target as..." is not an option available in firefox, its only available in ie.  The closest option available in firefox is the "Save Link as..." option which does not present an mp3 file to download as ie does.  In firefox, it doesn't matter if you right click or left click, it still only presents an html file to save, not an mp3.

The mission is to download an mp3(or stream link) file, not an html file.  ie allows me to do this, firefox does not....why not?

For you to duplicate my dilemma, you have to subscribe to the streamlink subscription service($7/month) and then attempt to download a stream or mp3 of the specific show that you would be interested in downloading.
(Reporter)

Comment 3

9 years ago
No one is following up on this.

Is anyone going to bring mozilla firefox up to the task of being able to respond to the url above as a "streamlink" account holder and having the same ability as ie to access/download the mp3 files that ie can with their "save target as" menu choice?
(Reporter)

Updated

9 years ago
Alias: "save_target_as"
(Reporter)

Comment 4

9 years ago
(In reply to comment #1)
It's been a month and I'm at a loss as to how to get this issue looked at. You have been the only one to even offer a comment but I realize that in order to replicate this issue, one would have to be a subscribed client of the "Coast to Coast AM" "StreamLink" service.

I'm a newbie in the bugzilla environment and I'm stuggling with issues like trying to get my chosen key words accepted.  I've been unable to find much more than the basic "Bugzilla" and "Bug Writing Guidelines" pages to aid me in my study.

Perhaps this issue would better be addressed as an addition to future versions.  I haven't seen where I could bring the shift that focus.

If it is it unreasonable to ask for someone to have to spend $.6.95 for the minimum one month subscription in order to duplicate this behavior, then I have to give  up, I guess.
We typically aren't going to pay for a subscription to a site to try to find out what they're doing.  Typically webmasters will file a bug with a description of the inconsistency.  Maybe IE implements save link differently, or the site offers different links to Firefox, but unless we can get a better description, it's not really something we're going to follow up on.  Maybe you can get the webmaster to try it and explain what's going on?
(Reporter)

Comment 6

9 years ago
(In reply to comment #5)
I have sent the following in a "Support Form" email form to the c2cam site:
> The "Save Target as..." option is not available when loggedin to the c2cam   > streamlink service using the Mozilla Firefox browser.  As a subscriber, I am > upset at this bias against firefox but cannot get the bugzilla communnity to > 'fix' this problem since in order to replicate the problem, the tech has to  > have subscriber access to the c2cam streamlink service.
> 
> Is there a way for a technician to have subscriber status while he/she  is   > working on fixing this?
> 
> Is this fix actually a webmaster side issue on the streamlink side?
> 
> The bugzilla community is available for your personal involvement to help    > solve this.  It's free to join.  You don't need to join to see the posting of > this issue.  Fire up...
> https://bugzilla.mozilla.org/
> ...and enter "482355" in the "Find a bug:" box to see the current status.
(Reporter)

Comment 7

9 years ago
( a retransmission of the 6 may posting that hopefully is more 'readable'...if it is, please, someone who knows how, delete it and let this replace it.  Else, delete this and I'll give up trying to edit)

I have sent the following in a "Support Form" email form to the c2cam site:
> The "Save Target as..." option is not available when loggedin to the c2cam   
> streamlink service using the Mozilla Firefox browser.  As a subscriber, I am 
> upset at this bias against firefox but cannot get the bugzilla communnity to 
> 'fix' this problem since in order to replicate the problem, the tech has to  
> have subscriber access to the c2cam streamlink service.
> 
> Is there a way for a technician to have subscriber status while he/she  is   
> working on fixing this?
> 
> Is this fix actually a webmaster side issue on the streamlink side?
> 
> The bugzilla community is available for your personal involvement to help    
> solve this.  It's free to join.  You don't need to join to see the posting of 
> this issue.  Fire up...
> https://bugzilla.mozilla.org/
> ...and enter "482355" in the "Find a bug:" box to see the current status.
(Reporter)

Comment 8

9 years ago
Yeh! It worked.  I just received today, finally, a response from a "customer 
care" person at the subscription service but his response is in the form of 
stating that they're just getting over some kind of in-house breakdown(?) and he was merely asking if this 'trouble ticket' had been resolved in the mean 
time.

The following is my email response to him:
*****
Dear Mr. Jeff R......If you or any of your techs haven't done anything about 
this issue, then no, it is not resolved.  Your site is refusing my login right 
now so I can't personally verify that it still exists but the bugzilla 
community and truly, c2cam streamlink subscribers who are firefox users all 
over the globe are waiting.  I just happen to be the only one that is taking 
the initiative within the FOSS(Free and Open Source Software)/Bugzilla 
community to see what you can do to allow those who would be willing to 
trouble-shoot this from the consumer end to attempt to solve this without 
having to pay the subscription if only to be able to demonstrate this 
malfunction when using firefox to access the streamlink subscription service.  
I can't speak personnally for those who would come forward, the need for the 
subscription to demo the problem has chased many away I'd guess.

If the thought on the c2cam side is that you are not sure how to regard having 
other browser access to the service by solving this in-house, I'm hoping that 
eliminating the need to pay for a subscription in order to try and solve this 
will draw FOSS expertise out of the ether to tackle this.  We are all 
volunteers and the Bugzilla culture and myself or anyone else associated with 
the Bugzilla community cannot predict what kind of response will be generated 
by some sort of non-paying access but whatever concession can be made, I would 
pass on in the forum.  Only then will the sense as to what kind of expertise or 
numbers will come forward.  As you see below in the last lines of this original 
email I sent, you or techncians who work for you can check out the current 
thread of response by following the link given.

If this would indeed be a solution to be found by Bugzilla community 
involvement prompted by some sort of arrangement that would allow members 
unpaying access to the service, obviously, there would have to be some kind of 
control that would prohibit abuse of this access that your subscribers, myself 
incuded, pay for.  Perhaps a limited number of free downloads would have to be 
justifed by forum postings that would have to be more than just "talk."  They 
would have to demonstrate expertise and be presenting valid steps toward the 
solution or loose further free access.

While I will be following the postings in the forum with anticipation, I can 
honestly state that my personal experience in professional software development 
is definitely on the amateur side.  I'm simply a concerned Streamlink service 
subscriber who is involved in the FOSS and Bugzilla community and am trying to 
see if its possible to get us all on the same page.

I will go back to the forum after sending this off and report that you've 
gotten back to me though it appears for the moment, you aren't prepared to 
respond to my original email from earlier this month.

Thankyou for your response, 3 weeks later or not,
*****

At this point and in the event that someone from the service either responds to me or actually participates in this forum, I hope that this posting is a rebel call for Firefox developers who may now have seen the possible opening for resolving this will be ready and waiting.....in the event that the Streamlink service is eager and willing to enlist our effort....

Updated

8 years ago
Alias: "save_target_as"

Comment 9

7 years ago
Unable to test this bug.

No further comments since 2009, so I am now going to close this bug as RESOLVED WONTFIX due to the fact it will most likely work in Firefox 4.0.1


If this bug still exists, please comment and reopen this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX

Comment 10

7 years ago
(did debate marking as invalid as this is not a bug, firefox is functioning as expected and returning the target and offering to save it)

Please correct me if closing this bug was incorrect.

--
Sam
You need to log in before you can comment on or make changes to this bug.